0

Site has a custom Membership status that is no longer required. They try to delete that Status but it says 'no way jose: This membership status cannot be deleted as memberships exist with this status'. They go do a Membership Search - find none with that status. I check in DB as well in case some membership belong to contacts in Trash - still no results.

I suggest they set it to 'disabled' as a temporary solution.

Why won't it allow them to delete via UI. I tried replicating with a brand new custom Status on demo but that could be deleted.

1

Ok, found it. If you have logging 'on' - and you have a membership which was at some point in history 'that' status - then when you search you find 'no results' - but there is a record in log_civicrm_membership

and presumably it is not be able to be deleted in case the record needs to be reverted.

If that is the issue, then perhaps the error message needs to incorporate that fact.

or should the membership status be ok to delete even with data in the logs?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.