2

I've looked around and seen several similar issues to this, but not exactly the same. I have civimail configured to send emails just find and the tracking url works initially, but ends in failure as it cannot find the civicrm.settings.php file in sites/default/

The problem may be that I have multiple sites running on a common installation of drupal. But, the sites folders are named the same as the virtual site (e.g., sites/example.com for example.com). It's not clear to me why Civicrm is failing to detect the proper path for the civicrm.settings.php file.

For reference: Civicrm 4.6.14, Drupal 7.42

  • When you say you have multiple sites running on one Drupal install, how are you doing that? Domain Access? If so, could you edit your question to show how you're determining which site is which? – Jon G - Megaphone Tech May 26 '16 at 21:27
  • same thoughts. are you using a single civi for a single drupal, but that drupal is part of multisite, or are you tieing a single civi in to multiple drupal so each drupal site is integrated with the one civi, or do you have a civi for each of your multiple drupals? – petednz - fuzion May 27 '16 at 22:54
1

KEY thing is that when you have a Drupal multi site config - make sure that each civicrm is in its corresponding /sites/example.com/modules

You can structure that too: put your CiviCRM versions in one central place eg /var/www/ so you have a civicrm/4.6 a civicrm/4.7 etc - then add a symbolic link in each projects /modules directory to the /var/www/civicrm/4.x version it's on.

This way you can now easily update both minor Drupal and minor CiviCRM versions across all your sites/projects!

EDIT: example: in /home/karin/org.ca/modules

lrwxrwxrwx. 1 karin karin 20 Jan 15 13:37 civicrm -> /var/www/civicrm/4.6

| improve this answer | |
  • Ah, I see -- I will try this. I did have one common install of civicrm in sites/all/modules for easy of updating, but to be honest it was more trouble then it was worth (different extensions, etc., across sites). – jimgde May 27 '16 at 12:59
  • Ok, tried the symbolic link approach but it gave me a similar error (couldn't find civicrm.settings.php at /var/www/civicrm4.6/../../..//default/sites/. Moved it into the site module file proper and it works now. Guess that's the only way? – jimgde May 27 '16 at 13:34
  • Then that explains the issue! And with the symlinks you'll keep your ease of updating; Each site/project will also need its own CiviCRM extensions dir. – KarinG - Semper IT May 27 '16 at 13:36
  • That symlink needs to be in the site's /modules (yes you can just put civicrm in there - but with a symlink to your civicrm repository it's easier to update); remember to clear any and all cashes; drush rr if needed! We have 30-40 sites/projects using this setup - and they can all civimail. – KarinG - Semper IT May 27 '16 at 13:40
  • Hmm. Then I'm not sure why it wasn't working for me with the symlink, which I did place in the sites modules' folder...I'll keep experimenting, but for the time being it'll work with civicrm in the module folder directly. Thanks! – jimgde May 27 '16 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.