1

Our website is being hosted by CiviHosting, but our Domain and Email are with another hosting company. The other hosting company just changed the DNS to point to CiviHosting, so that our domain would work with the CiviHosting account, and now I can't edit the contribution pages I made (or create a new contribution page). Specifically, I went to contributions >> manage contribution pages and then chose "configure" and then "Title and settings" for one of the pages and it redirected me to the /wp-admin Wordpress dashboard.

I tried a different page same thing.

I tried creating a new page and it let me type everything in but when I hit "save" it took me back to the /wp-admin page.

I tried deactivating and reactivating the plugin. Didn't work.

I tried removing all the files from the server through FTP, and reinstalling a brand new installation of CiviCRM. Didn't work.

I removed the new installation and put my old civicrm files back. Didn't work.

I have been Google Searching for a while and I tried finding config.settings.php as many sites suggest, but the only thing I could find was config.settings.php.template which I did attempt to modify in the way they described (changing the base URL) and that didn't work either. I changed it back to the original and re-uploaded it via FTP.

I looked through civicrm.config.php in case that was the file I was supposed to modify, but couldn't find a place to change the URL.

I tried going through the settings menu of CiviCRM, specifically the resources and directories paths and they all look like relative references (see attached) so I'm not sure what I'd change.

If you go to the actual pages, they do work, but I have no way of modifying them... (here's an example live page: http://sweetfields.org/civicrm/?page=CiviCRM&q=civicrm/contribute/transact&reset=1&id=1)

Any idea what broke and how to fix it?

Thanks!

UPDATE: I just noticed that when you click on the link I provided in this post, it is referencing an old version of the site... I removed the black login bar at the top of the page. If you go to sweetfields.org now you'll notice the black bar is gone but for some reason it's there for the CiviContribute page... the plugin must be somehow referencing old files?

UPDATE 2: Found the file! But, it already has the correct URL in it for the base_url: " define( 'CIVICRM_UF_BASEURL' , 'http://sweetfields.org/');" so I'm guessing that's not the problem?

UPDATE 3: Should I delete all tables in the database that start with "civicrm_" and delete all files and then try re-installing?

1

For a domain change, look at the civicrm.settings.php file the 'CIVICRM_UF_BASEURL' is the field you are looking for.

For CiviCRM version 4.7.x this will be in wp-content/uploads/civicrm/
For CiviCRM versions 4.6.x and lower this will be in wp-content/plugins/civicrm/

You may also need to make changes for WP, but this is what you'll need to start with for CiviCRM. In addition, the CIVICRM_UF_BASEURL setting must match the Site Address (URL) in the WP General Settings.

Update: Ensure that CIVICRM_UF_BASEURL reads as below:

define( 'CIVICRM_UF_BASEURL'      , 'http://sweetfields.org');
  • Thank you for answering, hopefully you can help me a bit more I'm still stuck. I truly cannot find that file. I just downloaded CiviCRM recently so I imagine I have 4.7.x. There is no uploads folder. I looked in the other folder for 4.6.x versions too it's not there. I looked on CiviCRM's core GitHub page (github.com/civicrm/civicrm-core) and I can't find the file either. Do you mean civicrm.settings.php.template? I can find that file in wp-content/plugins/civicrm/civicrm/templates/CRM/common – Barbara Donnini Jun 6 '16 at 12:46
  • There has to be a civicrm.settings.php file. The file should be in one of those places. Can you search the files via file manager to find it? I would expect you to check in /home/<your-user-name>/www/www/wp-content/ to find the file based on the link you gave above. Then look in uploads/civicrm. If that is not there, look in plugins/civicrm – Kevin Cristiano Jun 6 '16 at 13:11
  • I just posted a screenshot of the search results, it doesn't look like it's there. It seems like others have had this issue of the missing file, but I'm not sure what to try first I'm scared of breaking the site... civicrm.stackexchange.com/questions/9776/… and forum.civicrm.org/index.php?topic=34290.0 I also checked FileZilla and don't see the file there either. – Barbara Donnini Jun 6 '16 at 13:45
  • Also in the installation it says to create this folder "<wordpress path>/wp-content/plugins/files/ directory " which I did, and I checked that folder but the settings file is still not there. – Barbara Donnini Jun 6 '16 at 13:50
  • I can try re-installing it again, but it seems to be pulling information from the old site somehow (I guess the database?)... I'm fine with starting completely over but I can't even figure out how to do that, it has all my pages saved apparently. – Barbara Donnini Jun 6 '16 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.