1

For online contributions, the only email that gets sent is when the contributor pays immediately (receipt). Thank you emails are not automatically sent and I cannot work out whether this is functioning as designed. When the direct deposit option is selected, no email is automatically sent out.

In addition there is a setting on the profile we use for contributions to notify when the form is submitted. This has not been working either.

After some research, I enabled the CiviContribute setting to automatically email invoices (enable tax and invoicing section) which made the email notification of profile submissions work for some reason, but not the invoice/receipts for pay later.

Any suggestions on how I can troubleshoot? CiviCRM v4.7.8 but this has been an issue since 4.7

Edit/Update: If I disable automatic email of invoices, no emails are sent unless pay now (including profile submission email). If I enable automatic email invoice I get a pdf invoice every time as well as a profile submission email. This is fine as a workaround but if anyone knows a way to get it to email without a pdf attachment, that would be better. I received intermittent emails without pdfs (one with an amount, one without amount) while I was testing a couple of hours ago, then the pdfs started arriving consistently, so I customised those as a way forward.

bumped to the homepage by Community 9 hours ago

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

Looks like this bug but it should have been fixed in 4.7.4

  • Almost the same, except the pay later instructions do appear on the contribution page when that option is selected. As another test I disabled the automatic emailing of invoices and the notification of profile submission has stopped working again. I cannot figure out how they are related. – Jambo Jun 6 '16 at 17:33
  • Well I don't know what is going on but it seems to be working after all that enabling and disabling of various options. I can't say which thing did the trick because I have reverted to the original settings when the problem as when the issue was reported. I guess something has been overwritten. Or.. could it be some kind of caching issue? – Jambo Jun 6 '16 at 18:06
  • Now all I need is for the receipt to show an amount... – Jambo Jun 6 '16 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.