0

Not exactly sure what happened, but now the Submit Credit Card Membership option is not available in the Admin side of a Joomla install (v3.5.1). All seemed to be working fine, but then it disappeared. I tried recreating the Payment Processor and selecting it in the Contribution Page, but no luck. Then I opted to update to CiviCRM to 4.7.8 to see if that was the issues, still no luck. I am hoping it is just some sort of reset, otherwise our site is dead in the water with a conference coming up.

2

Looking at your issue: See CRM-15394

David Greenberg added a comment - 30/Sep/14 12:03 PM The back-office 'Submit Credit Contribution' feature is only available when the site has at least one configured payment processor of the type that allows credit card data to be entered within CiviCRM forms. This includes Paypal Pro, Auth.net and iATS. The link is hidden on the demo because the configured 'Test Processor' does not support this.

  • I think that may be out of date - I see the link on the Drupal Demo but not on Joomla Demo. – Sanjay Jain Jun 6 '16 at 21:18
  • NOTE: This is for Joomla, specifically, as per Scott's inquiry and as you noted below. We have tested here at the Sprint. It is confirmed that Dave Greenberg's explanation is correct. – BruceW Jun 7 '16 at 0:45
  • @Scott - note that to process credit card payments inline in the backend you'll need PayPal Pro (not Standard) – KarinG - Semper IT Jun 7 '16 at 1:43
  • Thanks Bruce - I added an authorize.net (dev sandbox) account and the link showed up on the Joomla demo. Not sure why the Drupal demo works with just a test processor though – Sanjay Jain Jun 7 '16 at 12:23
  • Now I am really concerned, as I said using PayPal Standard the link and button where there and usable then it disappeared. So given that it was not suppose to be there to begin with, how can we process payments in Admin given our situation? Thanks for sny direction. – Scott Jun 7 '16 at 21:04
0

I am seeing the same thing in the Joomla Demo - I think you have found a bug. Please report it at https://issues.civicrm.org

Note this is only in Joomla, Drupal demo shows the link.

Update: Adding an authorize.net account on demo made the link appear. You could test your payment processor account on another instance to see if that's the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.