0

I have auto-renew required set in my membership types, but users are able to uncheck this and continue to join as non-auto-renew. I've cleared all caches server and client side.

Since it's required, I'd expect to see a red asterisk next to the checkbox, or see that the checkbox checked, and greyed out. Neither of these happen.

Is there something else I need to set other than the setting in membership types?

Thanks

Affects versions:

Civi 4.6.23

Civi 4.7.13

Drupal 7

6
  • Have you tried replicating on a demo site to confirm what you are seeing is what is expected? civicrm.org/demo
    – petednz - fuzion
    Commented Jun 14, 2016 at 20:42
  • I could, but not for 4.6 on Drupal. Unfortunately, for 4.6 the only option is Joomla. Probably worth some experimentation on some version.
    – Peter_
    Commented Jun 16, 2016 at 15:52
  • I just tried it on 4.7...looks like a bug.
    – Peter_
    Commented Jun 16, 2016 at 16:23
  • will you be adding to jira then? if so pls also add as an answer to your own question
    – petednz - fuzion
    Commented Jun 16, 2016 at 20:20
  • Trying to use hook_civicrm_validateForm as a workaround, but I'm not sure how to access the checkbox data. I can see it when I print_r($form)...It's in a HTML_QuickForm_checkbox Object and I've no idea how to get to it.
    – Peter_
    Commented Nov 7, 2016 at 8:27

1 Answer 1

1

This is a bug affecting versions 4.6.23 and 4.7.13.

https://issues.civicrm.org/jira/browse/CRM-19608

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.