2

Just discovered that scheduled reminders have stopped working and appear to have done so since updating CiviCRM to v4.7.8 on 3rd June. The following error message is in the scheduled jobs log: Summary Finished execution of Send Scheduled Reminders with result: Failure, Error message: Cannot build query. Variable "@memberTypeValues" is unknown. Details Parameters parsed (and passed to API method): a:1:{s:7:"version";i:3;}

Full message: Finished execution of Send Scheduled Reminders with result: Failure, Error message: Cannot build query. Variable "@memberTypeValues" is unknown.

Other points to note:

  • Wordpress version 4.5.2
  • Other CRON is working
  • No extensions are installed
  • Scheduled mailings are going out OK

Can anyone tell me where I should be looking for errors or are there any known bugs? Many thanks

  • look for civicrm Error logs in - .../sites/default/files/civicrm/ConfigAndLog - if you don't have any log then try to look for PHP error log – Ramesh - ARTECH Consultancy Jun 16 '16 at 11:13
  • Thanks Ramesh. I appreciate your help. Forgive my ignorance but I am a newbie on this kind of thing. The only log in ConfigAndLog on 3rd June was on an ini. file (Config.IDS.ini) but there dont appeaer to be any errors. Can you tell me where I should look for PHP errors please? – peterb Jun 16 '16 at 12:12
  • it depends on the server setting but normally you can find the error against this folder /var/log/httpd/error – Ramesh - ARTECH Consultancy Jun 16 '16 at 15:03
  • I've contacted my host to see if there are any php errors in the log. Although there was initially a security issue whereby my IP address was blocked, they have cured that and said "now the security rule triggered is fixed, there seems to be a remaining issue and it looks to be to do with how CiviCRM is coded". Scheduled reminders are still not going out as part of the CRON job, nor can the job be fired manually. – peterb Jun 22 '16 at 17:24
  • Today, I've updated civicrm to v 4.7.9 but the error message "Cannot build query. Variable "@memberTypeValues" is unknown".is still appearing when running administer/system settings/scheduled jobs/send scheduled reminders. All other scheduled jobs and CRON appear to be running normally. – peterb Jul 7 '16 at 15:40
1

Yesterday, the scheduled reminders started working again! This was after I had disabled and then re-enabled 'Membership Types' in Administer/Civimember and also upgraded to v 4.7.10 Hope this helps anyone having the same problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.