3

Scenario. I have a field set made up of 3 Contact Reference fields, eg c1, c2, c3.

I have a webform with 4 contacts, cid1 is current user, cid2 etc are set as Static Fields and I was hoping they would show the contacts already referenced for cid1.

On cid1 i have the custom fields set to show, and for cid2 it is set to show c1, etc

The form remains blank.

My test contact did not have a c3 set. So i found a name (component was set to autocomplete) and I submitted the form with c1 and c2 showing as empty (ie existing contact reference contacts were not loading).

Outcome was a c3 was added to my record. So that last bit works fine.

Should the fields load with existing data if there is some? Have i set something up wrongly?

Happy to add screenshots etc if that helps others follow.

  • 1
    Hey Pete - yes please add some screenshots - happy to see if I can help think this one through! – KarinG - Semper IT Jun 21 '16 at 12:08
  • PS - not sure if it's possible - but I'd like to find out too – KarinG - Semper IT Jun 21 '16 at 12:19
  • Where is the link to the webform coming from? From within Civi, or from within Drupal? If from within Drupal, is the link being generated by a view or some other means of controlling the link? – Allen Hutchison Jun 21 '16 at 14:17
  • Related question: civicrm.stackexchange.com/questions/9195/… – Allen Hutchison Jun 21 '16 at 16:54
  • THanks both. I will update my question to try and clarify but i don't think the latter is related as that is dealing with 'related' contacts, and I am talking about 'contact reference' (though I may yet change to a relationship) – petednz - fuzion Jun 21 '16 at 19:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.