1

I have just upgraded from 4.6.18 to 4.7.8. The upgrade was successful but when I try to open CiviCRM menu items I get the following error:

Fatal error: require_once(): Failed opening required 'CRM/Core/Payment/Ewayrecurring.php' (include_path='.:/var/www/test/sites/all/modules/civicrm:/var/www/test/sites/all/modules/civicrm/packages:.:/var/www/test/sites/all/modules/civicrm:/var/www/test/sites/all/modules/civicrm/packages:/var/www/test/sites/all/modules/civicrm/vendor/tecnickcom:/var/www/test/sites/all/modules/civicrm/vendor/phpseclib/phpseclib/phpseclib:.:/usr/share/php:/usr/share/pear') in /var/www/test/sites/all/modules/civicrm/Civi/Payment/System.php on line 59

I can't find reference to this anywhere. Has anyone else seen this issue?

When I reverted to CiviCRM 4.6.18 and then attempted to disable eWayRecurring I got this error:

I have reverted to Civicrm 4.6.18 and when I attempt to disable eWayRecurring extension I get the following error:

Fatal error: require_once(): Failed opening required 'CRM/Core/Payment/Ewayrecurring.php' (include_path='/var/www/test/sites/default/files/civicrm/extensions/com.pogstone.contenttokens/:/var/www/test/sites/default/files/civicrm/extensions/com.cividesk.helptab/:/var/www/test/sites/default/files/civicrm/extensions/uk.co.vedaconsulting.mosaico-1.0-alpha4/:/var/www/test/sites/default/files/civicrm/extensions/com.pesc.sparkpost-1.1/:/var/www/test/sites/default/files/civicrm/extensions/coop.palantetech.nodrilldown-master/:/var/www/test/sites/default/files/civicrm/extensions/uk.co.vedaconsulting.mailchimp/:/var/www/test/sites/default/files/civicrm/extensions/org.civicoop.membershippayment-master/:/var/www/test/sites/default/files/civicrm/extensions/nz.co.fuzion.extendedreport/:.:/var/www/test/sites/all/modules/civicrm:/var/www/test/sites/all/modules/civicrm/packages:.:/var/www/test/sites/all/modules/civicrm:/var/www/test/sites/all/modules/civicrm/packages:/var/www/test/sites/all/modules/civicrm/vendor/tecnickcom:/var/www/test/si in /var/www/test/sites/all/modules/civicrm/Civi/Payment/System.php on line 52

Any help would be appreciated.

Regards Martin Fuggle

2

It looks like you had at some point set up the eWay Recurring extension. Looked at the list of paths, it doesn't seem to be installed currently.

I looked at line 59 in Civi/Payment/System.php, which your error references. It seems like that function is running based on the payment processors you have configured.

The solution is to either: a) Install the eWay Recurring extension it's 4.7-compatible); or b) Go to Administer menu » System Settings » Payment Processors and delete your payment processor that uses eWay Recurring.

  • Many thanks for your help. I reverted to CiviCRM 4.6.14 and was then able to disable the eWay recurring extension and uninstall it. I then upgraded to CiviCRM 4.6.18 without problem. – Martin Fuggle Jul 3 '16 at 22:09
  • Glad to help Martin! Please help to make Stack Exchange more helpful to others by upvoting and marking as "accepted" answers that are helpful! – Jon G - Megaphone Tech Jul 3 '16 at 23:08
  • Certainly I will do what I can. – Martin Fuggle Jul 4 '16 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.