0

We use CiviCRM 4.7.8. My organization hosts a childrens' activity every year during the summer. For this I created smart groups to see which children are signed up and who of our volunteers have responded/signed up.
As we are preparing for the new event this year, I wanted to update or make new saved searches for this year's event. But when I try to update the smart group's criteria or even when I try to make a new smart group from an advanced search, the criteria get reset to just 'participant is not test' and everything else I selected is removed from the search.
The only way to get my information now is to re-do the searches by hand every time.
I tried to reproduce the issue on the demo site, but was unable to do so. The demo-site however is running 4.7.10, which is not available for download.
I've tried clearing caches to no avail. Can anyone else using 4.7.8 confirm this issue? My search is for contacts that are listed as registered or present in the role of volunteer at a specific event.

0

You can try to use Search Builder to make your Smart Group as a work around for this problem

  • Thank you for this suggestion. It's not as intuitive as the advanced search but at least I can create smart groups again. – Maurice Jul 4 '16 at 15:28
0

There has indeed been some work on smart groups fairly recently - check to see if it's fixed in 4.7.9 (by upgrading a stage copy of your site) with one of these release candidates: http://dist.civicrm.org/by-date/latest/4.7.9-rc/

PS demo runs 4.7.10 - which is master so in this case it would be 4.7.9rc + a couple of bits that were not ready to make it into 4.7.9 in time.

EDIT: if this issue still persists in the newest release - the next step is to reproduce the issue on the current demo. If you can -> file a bug report on JIRA. If you can not -> then this is specific to your instance/config - either continune using the workaround OR find a few hours of time to pay for a consult by a CiviCRM partner in your area.

  • Before I found time to create a staging site to test the rc, 4.7.9 was released so I upgraded the regular site (we don't normally use a staging site). Unfortunately the issue with smart groups from advanced searches is not resolved in that version so I'm stuck with the search builder for now. – Maurice Jul 12 '16 at 7:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.