1

I have recently upgraded to 4.6.19 which has solved issues to do with the updating of smart groups. However if I add a contact to a smart group it does not show the status of 'added' but shows the status to be 'smart'.

1

I just tested this in 4.5.5 and 4.7.9 (sorry, don't have a 4.6 test environment) and the status of a contact added to a smart group is indeed "added", so unless it is a bug with your specific version, perhaps the contact you believe to have added actually fit the criteria of the smart group to begin with? In any case, upgrading will resolve the issue.

Kind regards, Tamar

  • I have just got around to testing this in 4.6.19 and it certainly seems to be in error. I have attached a youtube video which demonstrates the issue. youtu.be/D1kYw2lMJW8 – Martin Fuggle Aug 8 '16 at 7:38
  • Hi Martin - see if you are able to reproduce the issue on the demo site which is running the upcoming release version (4.7.11 at the time that I write this): dmaster.demo.civicrm.org - if you are not able to reproduce, then you will know that upgrading your version of Civi will resolve the issue - if you ARE able to reproduce it, then consider creating an issue ticket on JIRA: issues.civicrm.org/jira/secure/Dashboard.jspa - hope this helps! – Tamar Meir - Cividesk Aug 8 '16 at 15:59
  • Hi Tamar - I'll try to get that done today or tomorrow. – Martin Fuggle Aug 8 '16 at 23:39
  • Well - I waited for over a minute and the sandbox site didn't respond and seemed as if it had no intention of responding. AFAIK 4.6 is a LTS version so if the error is showing in 4.6 it would be a good idea to correct it. Unfortunately I am not a developer otherwise I would try to look at the code myself. – Martin Fuggle Aug 9 '16 at 4:36
  • I managed to logon to the sandbox and tried to test the issue above. Unfortunately it is not even possible to create a smart group on the sandbox system. It gives a DB error. I tried using Search Builder and Search and neither allow the creation of a smart group. I think the video that I have already created is sufficient to show that issue exists in the 4.6 LTS environment. – Martin Fuggle Aug 9 '16 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.