3

I have civi crm 4.7.8 on wordpress 4.5.3 and I've changed my website domain name. When I go to wp admin, i can see civicrm icon and go the taskboard, but I haven't civicrm menu. I supposed there are some changes to do in database to set new domain name ? Can you hep me ?

1 Answer 1

8

Below are the simplified instructions taken from Moving an Existing Installation to a New Server or Location, but specific to answer your question.

  1. Open the file wp-content/plugins/civicrm/civicrm.settings.php in any text editor and change the value for CIVICRM_UF_BASEURL with your new domain name For CiviCRM Version 4.7 open the file wp-content/uploads/civicrm/civicrm.settings.php

  2. Login into WP and navigate to

http://[your domain name]/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/setting/updateConfigBackend&reset=1

and clear cache and save the new base directory/path settings

  1. Rebuild CiviCRM menu by navigating to

http://[your domain name]/wp-admin/admin.php?page=CiviCRM&q=civicrm/menu/rebuild&reset=1

6
  • Thanks for your quick answer. In wp-content/plugins/civicrm, I haven't the file civicrm.settings.php (maybe because I'm in 4.7.8 version ?) I have civicrm.php but there is no URL in.
    – Laure
    Commented Jul 18, 2016 at 15:37
  • Was CiviCRM installed and working fine before the domain name change? If yes, then there should be civicrm.settings.php file in 'wp-content/plugins/civicrm' directory, as this file will be automatically created during installation.
    – Ghost
    Commented Jul 18, 2016 at 15:42
  • For CiviCRM Version 4.7 open wp-content/plugins/civicrm/civicrm.settings.php Answer edited for CiviCRM version 4.7, but seems I need peer review Commented Jul 18, 2016 at 15:43
  • Yes civicrm was working fine before the domain name change (no hosting changes).
    – Laure
    Commented Jul 18, 2016 at 15:49
  • @KevinCristiano Thanks for the edit. Laure - Can you please check the above mentioned directory for CiviCRM 4.7
    – Ghost
    Commented Jul 18, 2016 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.