2

I am unable to save a contact with a that has 2 or more repeatable custom groups with a required custom field. The validation fails.

I am using CiviCrm 4.7.9. Has anyone else experienced this?

  • David- may be worth setting up a comparable but simplified set of fields on demo and confirming if the problem occurs there and hopefully others will take a look before the demo site gets refreshed – petednz - fuzion Jul 19 '16 at 9:03
  • I added the Custom Group "Repeating field set" witch a single required custom field to dmaster.demo.civicrm.org. Here is a video of how to reproduce the error: youtu.be/xWIHBj5XiEs – David Hayes Jul 19 '16 at 20:26
  • Exactly 2 years later and I'm seeing this with CiviCRM 4.7.27 on WordPress. Did you find a solution? – Mick Kahn Jul 22 '18 at 22:23
  • I never did find a solution. – David Hayes Jul 22 '18 at 22:43
  • I have reported it as an issue lab.civicrm.org/dev/core/issues/274 (or at least I think I have - my first attempt at this) – Mick Kahn Jul 23 '18 at 17:47
1

I've just tried this out on the demo sites (WordPress and Drupal) CiviCRM 5.5.alpha1 and its still not working. I'll look into reporting it as a bug, but I have found a partial work round (though this isn't what I want).

The problem only occurs with the custom field set using the inline option, so you could use tab or tab with table.

  • That's good to know. – David Hayes Jul 23 '18 at 17:03
  • Oh something changed! By 'repeatable' I presume you mean multi-record. used to be that could 'only' work as a Tab but now I see the Help says "'Tab with Table' is recommended for customs data sets which allow multiple records." which implies it 'might' work with 'inline' – petednz - fuzion Jul 23 '18 at 19:21
  • That's certainly how I am interpreting this question and the problem I have. I see that in the help now, but it only says recommended. The option change when you select multi-record so if inline wasn't mean to work it should be removed (not the solution I want). The documentation suggests all should work, though its a bit muddled in that it doesn't say the tab with table is only for multi-record. – Mick Kahn Jul 23 '18 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.