0

(This has been replicated both on a Civi 4.6.19/Drupal 7.50 site and a Civi 4.4.6/Drupal 7.37 site, with the following versions of Civi Webform 7.x: 4.10, 4.14, 4.15)

We have a webform connected to a contribution page with membership options - not a priceset, just selected membership options from the membership types stored in Civi. The membership options are not showing up on the payment page, as seen below so the user cannot make a selection of membership type. Is this standard Civi webform behavior? If not, is there some setting or permission issue that we can modify?

enter image description here

1

Look for them on the Start page - and make sure you have configured the Membership (under the Webform tab) - as a user select. Note here you can also decide if you want live options or static - and if you go static you can decide which ones are available.

Add on: Before all this you will want to get into the Membership section under the Webform -> CiviCRM tab.

enter image description here

enter image description here

enter image description here

  • Karin - Thanks for the super screenshots but unfortunately this still does not solve my issue. I have the webform configured as you have it above, but the membership payment owed does not appear at the payment stage, as shown in my original screenshot. I'll need to continue troubleshooting on my end, but please know that I appreciate your help. – Lesley Carter - BackOffice Jul 21 '16 at 18:05
  • Are you positive you have Membership Fee checked? – KarinG - Semper IT Jul 21 '16 at 18:10
  • Yes, it is included. Even when I allow a number to be entered into that field, the amount is not carried over to the payment page. – Lesley Carter - BackOffice Jul 22 '16 at 14:35
  • You're definitively missing a setting/config somewhere - perhaps post screenshots of all relevant settings/config pages - if you want us to have a look. – KarinG - Semper IT Jul 22 '16 at 14:51
  • We figured it out for one of our clients (the more critical item)... thanks for all your help! – Lesley Carter - BackOffice Jul 29 '16 at 19:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.