It appears that the wysiwyg does not work well with ThemeForest themes. It does not load in certain pages like the title page of contribution pages. It works just fine when I use a default theme.

Suggestions on how to get this working and override the theme ?

  • What version of Civi? – Allen Hutchison Jul 22 '16 at 5:05
  • I have the latest 4.7.9 I believe. It appears to be an incompatibility with the theme but I don't know where to start looking to adjust. – Latinpolyguy Jul 23 '16 at 18:29
  • 1
    Are you running JetPack? I have seen similar issues with JetPack. – KilakwaBT Jul 24 '16 at 15:52
  • No jetpack, just the themeforest theme. I killed all the plugins and same effect. – Latinpolyguy Jul 28 '16 at 2:25

If anyone new is having this problem, the solution is to upgrade to CiviCRM 4.7.31+. CiviCRM ships with the BackboneJS library; so do certain WordPress themes. Sometimes that causes a conflict. Conflict mitigation was added in 4.7.31.

| improve this answer | |

Try installing this extension and then switching the editor to tinymce under administer - display preferences. Maybe it's a conflict with ckeditor.


| improve this answer | |
  • Yup, I tried that, first thing I did. It appears to be a theme incompatibility but I thought 4.7.9 addressed this. – Latinpolyguy Jul 23 '16 at 18:29
  • Use firebug or even just view-source to see what javascript files are being loaded. Possibly civi and forest are loading different versions of the same library. – Demerit Jul 23 '16 at 21:45
  • 1
    Latest from the theme forest developers... possible bug? In Karma/framework/truethemes/metabox/init.php at line 22, there is this function wp_enqueue_media(); which is a WordPress core function and not a function with our theme. I commented it out and now your CVICRM wysiwyg editor is loading properly. You can check with your plugin's author, why it's not working when wp_enqueue_media(); is used. I do not know what's the impact of removing wp_enqueue_media(); from init.php, because init.php is part of a third party open source metabox script. Thank you Denzel – Latinpolyguy Jul 26 '16 at 17:03
  • Did you get anywhere with this? I've a similar problem with the Karma theme. I have CKEditor working fine, but the profile selection tool in event set up - under the 'online registration' tab isn't working. – Graham Oct 14 '16 at 11:08

I am using a Theme Forest theme with similar problems, cannot select profiles, etc. I switch to WordPress TwentySeventeen theme, everything in CiviCRM functions normally (but the website looks like ^%^%). I select my profile needed and switch back to my Theme Forest theme. Just do this at a low traffic time for your site and most times it only takes a few minutes to do. I have never tried the wysiwyg but I assume this would work for this situation as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.