1

I am using Civi 4.7.9 and Wordpress 4.5.3.

When I create an Event and embed it in a Wordpress page, the entire Registration process is flawless, but only when I am logged in. When I test the process as the Anonymous User, it gives me the error:


Sorry but we are not able to provide this at the moment. You do not have permission to access this page.

Return to home page.

I have insured, multiple times that the Wordpress Role permissions are correct. I have also insured that all the event settings are correct and that it is a public event. I have also insured that all custom registration fields are accessible to an anonymous user.

I think that my only recourse may be blow out all my permissions and ACL's and rebuild until I hit the error again. However, I thought I would post here in case anyone had seen this before and could give me options before I take this drastic measure. Any ideas?

1

I know that you said you've looked at this, but it sounds like a permissions issue.

According to the documentation you need the following permissions:

View event info and Register for events:

If you plan to use CiviEvent and want to allow online event registration, enable these permissions. Be sure to assign permissions for the "anonymous" role if you want to allow un-authenticated visitors to view and register for events.

If you have custom fields you will also need this permission:

Access all custom data:

You must enable this permission for any role which you want to view or edit custom data fields. EXAMPLE: If your site uses Profile(s) which include custom fields, make sure the role(s) that need to access these Profiles have this permission. Be sure to assign this permission for the "anonymous" user role if you want to collect information using custom profiles with custom fields.

You can find more information here: Permission and access control

  • Thanks William! I have just quadruple checked that both of those permissions are assigned to the Anonymous User. It is the main reason I am stumped here because all settings are correct, but the error appears. I think it may be related to cookies/sessions but I am not sure if it is possible to manipulate or reset them...other than to clear all caches, which I have also already done. Any other ideas? Thanks in advance! – Vince Dimanno Jul 29 '16 at 16:53
  • Have you tried using a different browser that you haven't logged in on? – William Mortada Jul 29 '16 at 17:28
  • Yes...and I have people in different locations trying it out with no login access at all. So, the Anonymous User Role was created in WP on install, but perhaps it is not using the permissions in some way? Are there settings in the DB that could effect this? Thoughts? – Vince Dimanno Jul 29 '16 at 20:35
  • Sorry, I'm not sure what else to suggest. – William Mortada Aug 5 '16 at 22:16
  • Thanks for trying. I think I must re-stage it on my test site and step through the permissions setup again and try and catch the mistake. If it is anything other than "user error" I will post the solution here for others. – Vince Dimanno Aug 8 '16 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.