I'm working on a new CiviCRM implementation in Wordpress. I have imported contacts with an External ID in each record, imported contributions, memberships and relationships. The related contacts are not showing a valid membership by relationship and the Primary Member's membership record states "One contact is currently eligible to inherit this relationship."

I have tried deleting all records and reimporting in a different order; updating memberships; running update membership scheduled job.

I don't know where else to turn - I don't want to enter all of these manually.

Open to more ideas to solve the issue.

Thanks in Advance

Wordpress 4.5.3 CiviCRM 4.7.9

  • Have you tried edit/save on one of the Relationships to see if that triggers the inheritance?
    – petednz - fuzion
    Sep 5, 2016 at 11:32
  • Yes, it does nothing. Only deleting the relationships and recreating them which is tedious and I'm not getting paid for because it should be working out of the box, so to speak. Sep 5, 2016 at 20:42
  • are you saying that if you already have the membership and then import the relationship it doesn't work, and if you do it v v it also doesn't work
    – petednz - fuzion
    Sep 5, 2016 at 23:23
  • Yes - the memberships (and associated relationship types) were set up and the memberships were not inherited. I tried membership import first, then relationships AND the other way around. Neither time did the membership show up in the related contacts. Only be deleting the relationship and manually recreating it will cause the membership to be inherited. This is the first time that I've done this and it hasn't worked as it should. thanks for the comments! Sep 7, 2016 at 13:19

4 Answers 4


This is an on-again gone-again bug. At FF Towers we were never able to fix it and ended up writing an extension that did edit save on the membership to get it to work. Horribly hacky but day saved. Recommend more UTs.


I realize this question has been out here a long time, but I recently experienced a similar situation and solved it - my Civi version is 5.3.1 and I'm using it with Drupal version 8.6.3.

In my case, I had accidentally set up the Membership Type to be linked to Organizations, but had defined the Relationship to be "Employee of" rather than "Employer of". This meant that Civi went looking for contacts that the Organization was an "employee of" rather than contacts that the Organization was an "employer of" when it was time to create inherited Memberships.

There appears to be a display bug in Civi in which it detects that an Employer/Employee relationship does exist between the Organization and Individual even if the direction is reversed and it reports it as being "eligible." This seems to account for the reporting of eligible contacts but the failure to create the membership.

When I set up the membership type's relationship direction to use "Employer of," the membership inheritance began working. (In my case, I had to make a direct database update to the civicrm_membership_types table because Civi won't let you modify the membership type after memberships have been created. The update caused no data integrity issues for my situation. YMMV)

Or you can use this plugin to modify the relationship https://github.com/agileware/au.com.agileware.membershiprelationshiptypeeditor


Is the Relationship Type set properly in Administer > Civimember > Membership Types? Each Membership Type needs the specific kind of relationship (employer of, etc.) specified for inheritance to function correctly.

  • I set that up long before I imported the memberships. I even created a Test membership class with relationships, and imported a dummy file. Please ready my post fully - the system is recognizing that there are relationships that qualify for the inheritance, but it does not create that inheritance. Aug 8, 2016 at 16:09

I've noticed recently that CiviCRM doesn't properly account for relationships that inherently operate in both directions (such as the spouse relationship).

For example, we noticed a wife who did not inherit the membership her husband owns, due to her being contact_a in the spouse relationship record. Deleting the spouse relationship and re-entering it from the husband's record fixes the issue, at least for the time being (some couples seems to alternate who donates for a membership, which means we'd have to delete and redefine their relationships every year).

  • This makes sense since when you set a Relationship Type to work for related Memberships you have to specify if you are starting from A or B, so yes, bi-directional relationships (where each A and B ends have same description) will get confusing
    – petednz - fuzion
    Jan 30, 2020 at 19:44
  • @petednz BTW after more testing it seems I'm wrong about needing to define the relationship in the other direction to fix the issue - deleting the relationship and re-entering it from either spouse's record fixes the inherited membership. The several instances we found where the inherited membership was missing apparently had something to do with having been imported from SALSA. Feb 2, 2020 at 15:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.