2

Side Note: This worked before upgrading from 4.7.8 to 4.7.10.

When we go to Advanced Search (ourdomain/civicrm/contact/search/advanced): Address Fields, enter a Postal Code and a range (ex: Find contacts within 25 miles), and click "Search," CiviCRM returns an error like:

No matches found for: Proximity search to a distance of 20 miles from 78660, UNITED STATES: We could not geocode the destination address.

I went to the sandbox (http://dmaster.demo.civicrm.org/civicrm/contact/search/advanced ) to check/test this, but the sandbox does not offer the option to search by proximity to a Postal Code. The sandbox is running 4.7.11

Thoughts? Thanks!

3

Proximity search worked fine for me in 4.7.11 and 4.7.10. Proximity search is available on the demo if you select a geocoding provider (Administer menu » System Settings » Mapping and Geocoding).

I'd advise checking/changing your system's geocoding settings. If that doesn't work, please update the question with the settings that aren't working, this is likely specific to your settings.

  • 1
    Well paint me red and call me a cherry. I feel like a proper fool for not realizing the cause. Silly me! Thank you for the tip. You were 100% correct. I selected Google as our geocoder and it's working correctly now. – Jonathan Leistiko Aug 24 '16 at 17:13
  • 1
    Clearing the settings and re-selecting them worked for me after upgrade to 4.6.26, cleared the existing settings, saved, then re-selected Google and saved again. No Key needed for google :) – Darren Apr 11 '17 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.