1

Version 4.7.10 on Wordpress 4.6

Error when selecting Contacts->Manage Groups: DataTables warning: table id=DataTables_Table_0 - Ajax error. For more information about this error, please see http://datatables.net/tn/7

This is a fresh install. The error makes contact group unusable which makes the whole thing unusable.

Comment from my system admin: I've updated the nginx config without any success and also tried updating the PHP query string size limit, again without any success. I would say the next step would be to contact the civicrm maintainers and say that the query string is causing problems. Usually GET query parameters shouldn't exceed more than 255 characters, while the one above is closer to 1300. They should probably be using a POST request instead of GET.

UPDATE

Following the instructions from the datatables link above, I compared the demo site to my site.

-The suspect request URL is identical.

-Data transferred / size: demo site 0.05 kb. my site 0.19 kb. This is puzzling since the URL is identical!

-On the demo site request type is json. On my site, it says html.

-Both are GET requests. I also looked at Civi 4.6.21 on WP 4.5.3 and this same request is a POST request. So I guess they changed it to GET.

-Demo site runs Wordpress 4.5.3 and Civi 4.7.11. my site is Wordpress 4.6 and Civi 4.7.10

  • What do you see in your civicrm log file ? – jitendra - fuzion Aug 18 '16 at 9:19
  • Can you tell me where that log file is stored? – Nat Aug 18 '16 at 14:05
  • /var/www/<your_site>/sites/default/files/ConfigAndLog/log_file.log – jitendra - fuzion Aug 19 '16 at 4:37
  • I don't have a ConfigAndLog directory. Is this something I need to enable somehow? – Nat Sep 1 '16 at 19:03
1

I have tested the above issue against WP 4.6.1 and CiviCRM 4.7.11. I am running Apache 2.4, php 5.6 and MySQL 5.6. The OS is CentOS 6.

I cannot reproduce this error nor the one mentioned Ajax Error when trying to view relationships tab

I commented in https://issues.civicrm.org/jira/browse/CRM-19331 about this as well.

I would suspect the issue here is due to either a plugin conflict or something specific to the Hosting Configuration. I am interested if these issues are specific to a host or a specific configuration.

I'd disable all plugins (except CiviCRM) and see if you can trace errors in you apache and php logs. I would also revert to a default theme (CiviCRM demo sites are tested with TwentyThirteen) I'd also look at the CiviCRM logs. The CiviCRM logins should be in the /civicrm/ConfigAndLog directory that is stored in the WP upload directory in 4.7

I'd be interested if these issues are specific to a host or a specific configuration.

  • Hi, I found the ConfigAndLog directory. I see 2 log files in there but they are both dated from a few months ago. How do I get the system to log what's going on now? Thanks. – Nat Sep 21 '16 at 17:34
  • The solution was to review the php requirements again and ensure I had everything compliant. – Nat Apr 2 '18 at 17:13
0

I did made a test against Wordpress 4.5.3 and Civicrm 4.7.10 - Fresh Copy

I didn't get any error message as you have reported - may be you should try the same against demo to confirm

I guess this helps !!!

  • What do you mean by "against demo"? Thanks. – Nat Aug 18 '16 at 14:06
  • Refer: civicrm.org/demo - you can find demo instance which is a fresh copy with latest civicrm - If you find any issues in civicrm - you can test the same against demo instance -and If you could replicate the issue against demo instance. Then the issue is considered as core issue else you made some mistake in installation – Ramesh - ARTECH Consultancy Aug 18 '16 at 14:16
  • The demo does not run on Wordpress 4.6, so it's not an exact configuration. – Nat Sep 1 '16 at 19:06
  • 1
    please check this link for different version of demo civicrm.org/sandboxes – Ramesh - ARTECH Consultancy Sep 2 '16 at 8:15
  • demo wordpress 4.6 - wp46.demo.civicrm.org/wp-login.php – Ramesh - ARTECH Consultancy Sep 2 '16 at 8:16
0

I had a similar issue on my CiviCRM fresh installation (CiviCRM 5.10.4) -> IIS10 webserver.

Error used to happen on both Joomla (3.9.3) and WordPress (5.0.1) versions.

The problem was that we see any relationship or activities table (DataTables warning: table id=DataTables_Table_0)

So, what I did to fix this problem is to add the following values in the app web.config. Do not forget any of these or it won't work.

<system.web>
    <httpRuntime maxQueryStringLength = "12288" maxUrlLength="12288" />
</system.web>
<system.webServer>
    <security>
        <requestFiltering allowDoubleEscaping="false">
            <requestLimits maxAllowedContentLength="3000000000" maxUrl="4000000" maxQueryString="4000000" />
        </requestFiltering>
    </security>

    <httpErrors existingResponse="PassThrough"></httpErrors>
</system.webServer>

Hope this helps !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.