I'm trying to browse images in wysiwyg editor (via the kcfinder) (for example Event description) but I get an error due to misconf. I hits the file civicrm/civicrm/civicrm.config.php which loads civicrm/settings_location.php (which you have to create) but I'm missing something inside this file, Is there an example of it?


The settings_location.php file should not normally be required, but an example is described at:


The file civicrm.config.php should be able to handle bootstrap in most common configurations without settings_location.php. However, this depends on having somewhat plain/predictable directory structure, and it could break down when using things like (a) symlinks, (b) special filesystems, or (c) multi-tenant/multi-site installations.

| improve this answer | |
  • It is only required when I try to browse images with wysiwyg editor. i.e. /wp-content/plugins/civicrm/civicrm/packages/kcfinder/browse.php?cms=civicrm&type=images&CKEditor=ten_how_to_get_there&CKEditorFuncNum=0&langCode=en-gb It may be because I use WP Const & functions in my civicrm.settings.php which are not avail at that point. I have checked the templates/CRM/common/civicrm.settings.php.template and it uses macros i.e. %%dbUser%%. How do i set these macros? – Stoycho Aug 18 '16 at 8:50
  • The macros which appear in the civicrm.settings.php.template are generally applied during installation. (For civicrm-wordpress, you may recall an install screen that asks for DB credentials.) The alternative is to do it manually (e.g. cp wp-content/plugins/templates/CRM/common/civicrm.settings.php.template wp-content/uploads/civicrm/civicrm.settings.php and then search/edit anything with %%), although that would override any customizations in that file. – Tim Otten Aug 18 '16 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.