3

I am working on a wordpress website with civiCRM. Member signup with CiviCRM is working correctly. I need an admin approve the new wordpress users after signup. I used "New User Approve" wordpress plugin for this. When the user make payment and completes the signup the page will redirect to the CiviCRM dashboard by default. But because of I am using the new user approve plugin the newly created wordpress user is not active and so that user can't sign in successfully and can't access the dashboard. That results in an error message. So I need to show a Thank you page after submitting the registration details. How can I do it?

1
  • 1
    It's always a good idea to include your version of CiviCRM, your CMS ( i.e., WordPress) version and, for this question, the version of the relevant plugin, in questions. Can you please add those? Commented Aug 24, 2016 at 6:54

2 Answers 2

1

In order to do what Joe suggests pretty certain you will need to have installed Front End Page Options extension otherwise the 'redirect' option won't exist.

0

Go to Contributions -> Manage Contribution Pages -> Choose ( or create ) your page -> Configure -> Thank You page Redirect

6
  • Hi Joe, Thank you very much for your immediate response. But it is not working. Under configure I have the option Thank you and Receipt. I put Thank you page Header, Body and footer there, but still the user redirecting to the dashboard. Here is the url : mywebsite.com/register-now/?page=CiviCRM&q=civicrm%2Fcontribute%2Ftransact&_qf_Confirm_display=true&qfKey=e3efa2c08abfabc1a44b8e29ac136ec7_130&login=failed I put redirect url on profile settings of the two profiles I am using for member registration and collecting member details, but no use... Any idea ?? Commented Aug 24, 2016 at 19:49
  • The page shows following error: Sorry but we are not able to provide this at the moment. We can't load the requested web page. This page requires cookies to be enabled in your browser settings. Please check this setting and enable cookies (if they are not enabled). Commented Aug 24, 2016 at 19:51
  • One correction that url is : civicrm.mywebsite.com/register-now/?page=CiviCRM&q=civicrm%2Fcontrib‌​ute%2Ftransact&_qf_C‌​onfirm_display=true&‌​qfKey=e3efa2c08abfab‌​c1a44b8e29ac136ec7_1‌​30&login=failed I am using civicrm 4.4 Commented Aug 24, 2016 at 19:56
  • Yeah Jins see Petednz's answer above - you should install the Front End Page Options extension first Commented Aug 25, 2016 at 5:24
  • Looks like you may already have that installed. If not, please do. If so, as a test, set Thank You Page Redirect to any valid url as a test. Does that work? Commented Aug 25, 2016 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.