0

SOLVED by enabling OpenSSL support in PHP.ini file (remove ";" in front of the "extension=php_openssl.dll" line)

After upgrading to 4.7.10 (Wordpress 4.6), I receive an error when saving changes to a contact profile (the address in my case). Please find below the details, any quick help will be much appreciated as we're blocked right now with this issue. Thanks

BACKTRACE

0 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\Error.php(182):

CRM_Core_Error::backtrace()

1 internal function: CRM_Core_Error::handle(Object(PEAR_Error))

2 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\packages\PEAR.php(931):

call_user_func((Array:2), Object(PEAR_Error))

3 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\packages\PEAR.php(566):

PEAR_Error->PEAR_Error("Need PHP 4.3.0 or later with OpenSSL support for https:// requests", 2, 16, (Array:2), NULL)

4 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\packages\HTTP\Request.php(703):

PEAR->raiseError("Need PHP 4.3.0 or later with OpenSSL support for https:// requests", 2)

5 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Utils\Geocode\Google.php(126):

HTTP_Request->sendRequest()

6 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\BAO\Address.php(387):

CRM_Utils_Geocode_Google::format((Array:21))

7 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\BAO\Address.php(144):

CRM_Core_BAO_Address::fixAddress((Array:21))

8 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\BAO\Address.php(120):

CRM_Core_BAO_Address::add((Array:21), TRUE)

9 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\BAO\Location.php(69):

CRM_Core_BAO_Address::create((Array:83), TRUE, NULL)

10 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Contact\BAO\Contact.php(348):

CRM_Core_BAO_Location::create((Array:83), TRUE)

11 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Contact\Form\Contact.php(986):

CRM_Contact_BAO_Contact::create((Array:83), TRUE, FALSE, TRUE)

12 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\Form.php(423):

CRM_Contact_Form_Contact->postProcess()

13 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\QuickForm\Action\Upload.php(166):

CRM_Core_Form->mainProcess()

14 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\QuickForm\Action\Upload.php(133):

CRM_Core_QuickForm_Action_Upload->realPerform(Object(CRM_Contact_Form_Contact), "upload")

15 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\packages\HTML\QuickForm\Controller.php(203):

CRM_Core_QuickForm_Action_Upload->perform(Object(CRM_Contact_Form_Contact), "upload")

16 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\packages\HTML\QuickForm\Page.php(103):

HTML_QuickForm_Controller->handle(Object(CRM_Contact_Form_Contact), "upload")

17 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\Controller.php(351):

HTML_QuickForm_Page->handle("upload")

18 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Utils\Wrapper.php(113):

CRM_Core_Controller->run()

19 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(286):

CRM_Utils_Wrapper->run("CRM_Contact_Form_Contact", "Nouveau contact", (Array:1))

20 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(86):

CRM_Core_Invoke::runItem((Array:13))

21 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\CRM\Core\Invoke.php(54):

CRM_Core_Invoke::_invoke((Array:3))

22 D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm.php(1227): CRM_Core_Invoke::invoke((Array:3))

23 internal function: CiviCRM_For_WordPress->invoke("")

24 D:\xampp\htdocs\gdc\wp-includes\plugin.php(524): call_user_func_array((Array:2), (Array:1))

25 D:\xampp\htdocs\gdc\wp-admin\admin.php(222): do_action("toplevel_page_CiviCRM")

26 {main}

Désolé, nous ne sommes pas en mesure de fournir ceci actuellement. Need PHP 4.3.0 or later with OpenSSL support for https:// requests Message d'erreur détaillé Détails additionnels :

Array ( [callback] => Array ( [0] => CRM_Core_Error [1] => handle )

[code] => 2
[message] => Need PHP 4.3.0 or later with OpenSSL support for https:// requests
[mode] => 16
[debug_info] => 
[type] => PEAR_Error
[user_info] => 
[to_string] => [pear_error: message="Need PHP 4.3.0 or later with OpenSSL support for https:// requests" code=2 mode=callback

callback=CRM_Core_Error::handle prefix="" info=""] )

Retourner à la page d'accueil.

Fatal error: Uncaught CRM_Core_Exception: [0: Transaction integrity error: Expected to find active frame thrown in D:\xampp\htdocs\gdc\wp-content\plugins\civicrm\civicrm\Civi\Core\Transaction\Manager.php on line 107

0

The error message says:

Need PHP 4.3.0 or later with OpenSSL support for https:// requests

What PHP version are you using? CiviCRM PHP Requirements are currently:

PHP 5.5 or greater is recommended, but not PHP7 yet (see CRM-17789: Support PHP 7 ). PHP 5.3.10 is the bare minimum.

This might help re OpenSSL support: Enabling the openssl in xampp.

From the backtrace, the https request appears to relate to Google geocoding, so as a workaround you could try disabling that to get yourself up and running.

  • Thanks for the quick feedback. We're using PHP Version 5.6.15. I activated the OpenSSL support and it works ! Thanks very much – SemperFi Aug 24 '16 at 9:27
  • Great, glad this helped! If this solved your problem, Stack Exchange etiquette is to upvote and accept the answer. This lets people see that the question has been answered; it also improves CiviCRM Stack Exchange's statistics, helping us to get out of beta. – davejenx Aug 24 '16 at 12:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.