When I edit a group, it will not allow me to save unless I select a Parent group. Is Parent Group required? If a Parent Group was accidentally assigned, how do you remove it without assigning a new Parent?

CiviCRM 4.7.9 and WP

This image shows an example of a Group that does not have a Parent Group. When I edit the Group the settings, the Parent pull-down list is automatically populated with a group called "Not Used (Smart Group)". It is not possible to deselect or select "none". Also, there is an asterisk next to the parent group indicating that it is required.

enter image description here

The second image shows a Group that has a Parent, and I would like to remove this relationship. But it is not possible. When I try to remove the Parent and save I receive an error message that Parent Group is required.

enter image description here

  • This shouldn't be the case. Please update your question with a screenshot (and CiviCRM version) so folks can better help you? Aug 30, 2016 at 2:39

2 Answers 2


It appears that you're using CiviCRM in a multisite configuration. You may want to update this question and future questions to reflect that. Relatively few folks use it, and it affects the answer to this question.

There is also a [multisite extension][1 that can be used to control further permissions with regards to this.

In short - you don't normally need a parent group, but with multisite, you do. There's details on why here.

  • 2
    I did not know that - must make it a habit to read all of Jon's answers! Aug 31, 2016 at 23:56
  • 1
    You are amazing. We've been trying to fix this problem for a while now and this fixed it. We have a multi-lingual website and we tried to use CiviCRM's multi-site configuration for our directory listings, but could not get it to work. So we no longer needed it to be turned on. I just turned it off and our parent group problem is solved!! Thank you so much. So grateful! Sep 1, 2016 at 18:13

interestingly we hit this issue recently too. Not because we were actually using multisite, but because we had 'enabled' it so that we had the 'Associated Organisation' field available to us to help connect individuals to groups (ie show the User which were 'their groups' based on their relationship to an Organisation, and that Organisations 'association' with a Group.

I believe this is the relevant PR https://issues.civicrm.org/jira/browse/CRM-19122

  • Ah - should have read your comment on Jon's. Anyway, there is a potential fix for this ;-)
    – petednz - fuzion
    Sep 3, 2016 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.