2

Trying to upgrade from CiviCRM 4.4.5 to 4.7.11 in Wordpress 4.5/4.4 (problem doesn't change for either WP version) because it stopped working and just printed this when trying to view /wp-admin/admin.php?page=CiviCRM

Sorry but we are not able to provide this at the moment.
DB Error: unknown error

I downloaded v4.7.11, removed the old civicrm code and unpacked the new one, then addressed the settings file (I ended up generating a new settings file via /wp-admin/options-general.php?page=civicrm-install, dropping the database tables that where created, then putting in the DB credentials for the existing CiviCRM database).

Now I ran the database update script - /wp-admin/admin.php?page=CiviCRM&q=civicrm/upgrade&reset=1 - and it looked good, I clicked the button, the progress bar started moving... then this:

enter image description here

[Error: Upgrade DB to 4.5.beta9: SQL]
Error Field Error Value
Type    DB_Error
Code    -19
Message DB Error: no such field
Mode    16
UserInfo    UPDATE `civicrm_dashboard` SET `permission` = 'access my cases and activities,access all cases and activities', `permission_operator` = 'OR' WHERE `name` = 'casedashboard' [nativecode=1054 ** Unknown column 'name' in 'where clause']
DebugInfo   UPDATE `civicrm_dashboard` SET `permission` = 'access my cases and activities,access all cases and activities', `permission_operator` = 'OR' WHERE `name` = 'casedashboard' [nativecode=1054 ** Unknown column 'name' in 'where clause']
PEAR_Exception: DB Error: no such field in unknown on line unknown
- DB_Error: DB Error: no such field in unknown on line unknown
Exception trace
    Function    Location
0   CRM_Core_Error::exceptionHandler(Object(DB_Error))  unknown:unknown
1   call_user_func(Array, Object(DB_Error)) /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/PEAR.php:931
2   PEAR_Error->PEAR_Error('DB Error: no suc…', -19, 16, Array, 'UPDATE `civicrm_…')    /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/DB.php:976
3   DB_Error->DB_Error(-19, 16, Array, 'UPDATE `civicrm_…') /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/PEAR.php:564
4   PEAR->raiseError(null, -19, null, null, 'UPDATE `civicrm_…', 'DB_Error', true)  /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/DB/common.php:1905
5   DB_common->raiseError(-19, null, null, null, '1054 ** Unknown …')   /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/DB/mysql.php:895
6   DB_mysql->mysqlRaiseError() /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/DB/mysql.php:328
7   DB_mysql->simpleQuery('UPDATE `civicrm_…')  /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/packages/DB/common.php:1216
8   DB_common->query('UPDATE `civicrm_…')   /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Utils/File.php:333
9   CRM_Utils_File::sourceSQLFile('mysql://kansas:4…', '-- CRM-15211 UPD…', null, true) /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Form.php:196
10  CRM_Upgrade_Form->source('-- CRM-15211 UPD…', true) /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Form.php:387
11  CRM_Upgrade_Form->processLocales('/home/kansas/www…', '4.5.beta9')  /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Form.php:421
12  CRM_Upgrade_Form->processSQL('4.5.beta9')   /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Upgrade/Incremental/Base.php:80
13  CRM_Upgrade_Incremental_Base::runSql(Object(CRM_Queue_TaskContext), '4.5.beta9')    unknown:unknown
14  call_user_func_array(Array, Array)  /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Queue/Task.php:88
15  CRM_Queue_Task->run(Object(CRM_Queue_TaskContext))  /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Queue/Runner.php:214
16  CRM_Queue_Runner->runNext(true) /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php:52
17  CRM_Queue_Page_AJAX::{closure}()    /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Queue/ErrorPolicy.php:106
18  CRM_Queue_ErrorPolicy->call(Object(Closure))    /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Queue/Page/AJAX.php:54
19  CRM_Queue_Page_AJAX::runNext()  unknown:unknown
20  call_user_func(Array)   /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:278
21  CRM_Core_Invoke::runItem(Array) /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:86
22  CRM_Core_Invoke::_invoke(Array) /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm/CRM/Core/Invoke.php:54
23  CRM_Core_Invoke::invoke(Array)  /home/kansas/www/dev/krc_wordpress/wp-content/plugins/civicrm/civicrm.php:1227
24  CiviCRM_For_WordPress->invoke('')   unknown:unknown
25  call_user_func_array(Array, Array)  /home/kansas/www/dev/krc_wordpress/wp-includes/plugin.php:524
26  do_action('toplevel_page_Ci…')  /home/kansas/www/dev/krc_wordpress/wp-admin/admin.php:222
27  {main}   

Seems to me that the update script is trying to modify a table and needs the 'name' column, but there is no 'name' column..

Any help would be GREATLY GREATLY APPRECIATED!!!!

2

I don't know about this particular issue, but this sort of thing happens occasionally, especially when a version (like 4.4) has a long run of minor releases and you're jumping a few versions ahead. Since 4.4 was a LTS, a number of changes got backported to later 4.4.x releases, and it's hard to test the full variety of upgrade combinations.

My general suggestion would be to download CiviCRM 4.4.20, upgrade to that, and then upgrade to 4.7.11. If need be, try another stop at 4.6.20 along the way.

By breaking up the jump, you're following a couple of more heavily-trod paths (with more testing and real-world experience) rather than a possibly unique jump from your particular version.

  • How about 4.4.21 ? Thank you – Dan Mantyla Sep 13 '16 at 14:01
  • Either way. I don't know anything about the actual versions involved--this is more about the principle of breaking the upgrade into a couple of steps. – Andrew Hunt Sep 13 '16 at 17:43
  • I was able to upgrade to 4.4.21 successfully. However, upgrading to 4.6.21 was unsuccessful. [Error: Upgrade DB to 4.5.beta9: SQL] DB Error: no such field. UPDATE civicrm_dashboard` SET permission = 'access my cases and activities,access all cases and activities', permission_operator = 'OR' WHERE name = 'casedashboard' [nativecode=1054 ** Unknown column 'name' in 'where clause']` – Dan Mantyla Sep 13 '16 at 20:04
  • I fixed it! I had to ADD A COLUMN in civicrm_dashboard called "name" in between "domain_id" and "label" – Dan Mantyla Sep 13 '16 at 21:28
1

SOLVED!!

I had to add a column in the table that was giving me a hard time.

ALTER TABLE `civicrm_dashboard` ADD `name` VARCHAR(255) NOT NULL AFTER `domain_id`;

Here's trying to update from 4.4.21 to 4.6.21:

enter image description here

And here's after changing the column 'label' to 'name'

enter image description here

And here's after adding the 'name' column:

enter image description here

Yay!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.