0

When I go to the Admin > Extensions > Add New, I get the following error...

"Directory Unwritable Your extensions directory is not set or is not writable. Click here to set the extensions directory."

When click on the link, it takes me to the Settings - Upload Directories page, but it is totally blank.

Any clues please?

2

I guess you dont have write permission on Extension folder

What you need to do is try to find if you have Extension folder already

Administer -> system setting -> Directories - look for CiviCRM Extensions Directory

you should find a path in Civicrm 4.7.x ext folder will be created against the below location -

.../sites/default/files/civicrm/ext

If folder exist then try to navicate to the location in Command prompt or Winscp and provide write permission to the folder - this should fix the issue

refer to the below link - additional reading

Are there recommended directory ownership and permission settings for CiviCRM files?

https://forum.civicrm.org/index.php?topic=10545.0

I guess this helps!!!

2

This problem began for me after the 5.4.0 and my upgrade to 5.6.1 didn't help.

I added the override for the extensions directory in the civicrm.settings.php (found in /home/xxxxxx/public_html/wp-content/uploads/civicrm).

// Override the extensions directory. $civicrm_setting['Directory Preferences']['extensionsDir'] = '/home/xxxxxx/public_html/wp-content/uploads/civicrm/ext';

and now I can see the extensions, install and upgrade within CiviCRM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.