1

Joomla vers 3.51 CiviCRM Vers 4.7.6

I´ve done a migration to a dedicated server. I did the copy of files and database with Akeeba Backup, then edited the usual files: /administrator/components/com_civicrm/civicrm.settings.php /components/com_civicrm/civicrm.settings.php /administrator/components/com_civicrm/civicrm/civicrm.config.php /media/civicrm/ConfigAndLog/Config.IDS.ini

I opened civicrm, cleaned all cache, and checked all settings.

Everything seemed to work ok: menus, contact browsing, mailing browsing, but when adding a new contact, there is an error (at the end of this message).

I did a copy in a test subdirectory, deleted all civi tables, uninstalled civicrm and did a clean installation of the same civicrm version. Now I can add contacts without errors, all is ok.

Civicrm settings files are identical (besides the test subdirectory) between both installantions, so this is not the problem.

Any sugestions to find and resolve this problem?

#0 /var/www/clients/client562/web1961/web/administrator/components/com_civicrm/civicrm/CRM/Core/Error.php(182): CRM_Core_Error::backtrace()
#1 [internal function](): CRM_Core_Error::handle(Object(DB_Error))
#2 /var/www/clients/client562/web1961/web/administrator/components/com_civicrm/civicrm/packages/PEAR.php(931): call_user_func((Array:2), Object(DB_Error))
#3 /var/www/clients/client562/web1961/web/administrator/components/com_civicrm/civicrm/packages/DB.php(976): PEAR_Error->PEAR_Error("DB Error: unknown error", -1, 16, (Array:2), "INSERT INTO civicrm_contact (contact_type , contact_sub_type , do_not_email ,...")
#4 /var/www/clients/client562/web1961/web/administrator/components/com_civicrm/civicrm/packages/PEAR.php(564): DB_Error->DB_Error(-1, 16, (Array:2), "INSERT INTO civicrm_contact (contact_type , contact_sub_type , do_not_email ,...")

Any sugestions to find and resolve this problem?

1

Have you tried deleting everything in media/civicrm/ConfigAndLog and templates_c?

  • Hi, thank you for your answer. As it seemed to be a very extrange error, I did an installation in a test server of the same backup and it worked ok, so I deleted everything in the working server and did the installation again. All worked perfectly! It seems like some file was bad copied. Jorge – Jorge Jagoe Oct 5 '16 at 12:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.