0

After successfully trialing CiviCRM on a local desktop PC, we have decided to install on our hosted wordpress website. I am following the instructions as listed here to the letter (3rd attempt) - https://wiki.civicrm.org/confluence/display/CRMDOC/Installing+CiviCRM+for+WordPress

  1. Login to your WordPress site with Administrator level permissions.
  2. Go to plugins page:http:///wp-admin/plugins.php.
  3. Click the'Activate' link to activate the CiviCRM plugin.

When I try to go to Settings > CiviCRM Installer: http:///wp-admin/options-general.php?page=civicrm-install

All I get is this error - "Sorry, you are not allowed to access this page." And when I go to settings in the wordpress admin panel there is no CiviCRM options appearing.

So I am unable to proceed.

I have checked permissions and made all relevant folders writable (i think?). So not sure what the problem is? Any suggestions please?

  • If civicrm does not appear in your wordpress admin plugins list then I would suggest that civicrm is perhaps not installed correctly or in the correct directory. After unpacking the civicrm zip file, my civicrm files are in root/.../wp-content/plugins/civicrm and in the latter directory, the installed directories and files are as below: – peterb Sep 17 '16 at 9:37
  • Revised If civicrm does not appear in your wordpress admin plugins list then I would suggest that civicrm is perhaps not installed correctly or is in the wrong directory. After unpacking the civicrm zip file, my civicrm files are in root/.../wp-content/plugins/civicrm and in the latter directory, the installed directories and files are as below: Directories: [assets][civicrm][includes],languages][wp-cli] Files: [readme.md][civicrm.php][civicrm.settings.php][readme.txt][uninstall.php] Can you confirm that all those items are present? Note; there is a civicrm directory within civicrm – peterb Sep 17 '16 at 9:47
  • I completely removed and then reinstalled and checked all the paths were correct. – jkobier Sep 20 '16 at 4:18
  • I completely removed and then reinstalled civicrm and checked all the paths were correct. The problem I now have is that by default, civicrm is picking up MySQL settings that are defined in wp-config.php, and if I try to change these (DB_NAME, DB_USER, DB_PASSWORD) it wipes out the entire website. Luckily I backed up the config file! So I can proceed, I just cannot specify which DB I want CiviCRM to use, as I don't seem to be able to change from the one defined in wp-config.php. – jkobier Sep 20 '16 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.