• CentOS release 6.8
  • cPanel 56.0 (build 25)
  • Apache (v. 2.4.18)
  • PHP (v. 5.6.22)
  • MySQL (v. 5.6.30)
  • WordPress (v. 4.5.3)
  • CiviCRM (v. 4.6.19)

When clicking a button the client is forced to log back in using wp-login.php with a long redirect appended to the URL which changes of course depending on which button they pressed.

This was brought up when one of the clients tried to export a constituent report as csv but after snooping around trying to resolve the issue I have found that it happens on every grey button when in the CiviCRM backend.

Also I have not been able to locate any output in any logs as it is just redirecting.

I had a hunch that it had something to do with SSL being enabled recently but I haven't made way with that assumption either.

I also went ahead and updated CiviCRM to 4.7.11 to see if this issue would resolve itself and it made no difference, so for the sakes of not changing unnecessary settings/files I reverted back to CiviCRM 4.6.19

Any help as to what to do to get this to stop would be greatly appreciated as it greatly hinders what can be done in the backend.

2 Answers 2


It could be the SSL. Verify the home url (WordPress General settings) and the CIVICRM_UF_BASEURL in the civicrm.settings.php file.

These should match exactly including the https:// If not that can be the issue.

If it matches I would look for a plugin or theme conflict next.

  • I had to have looked at these several times and didn't noticed that the CIVICRM_UF_BASEURL had the www in front where the home URL did not. Changed it for both of them to match it is working great now. Thank you very much!!! :)
    – LJB
    Sep 19, 2016 at 14:37

In order to resolve this issue, I had to match the home URL in WordPress General Settings to the CIVICRM_UF_BASEURL in civicrm.settings.php file. Thank you @Kevin Cristiano for your help!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.