1

When I send out a bulk sms with an URL, the URL is changed before it is sent out.

Original message in template:

  • Hi John! Check out this link: wikipedia.org/somethingfunny

Received message on phone:

How to make CiviCRM not change this?

2

My preferred solution is to use this extension (which should be 4.4 compatible) rather than manually digging around the database. Hope that helps!

https://github.com/PalanteJon/coop.palantetech.nosmsurltracking

  • @Flying I wrote this extension! If it does NOT work on 4.4, please open an issue with the error message on its Github page. – Jon G - Megaphone Tech Oct 3 '16 at 16:47
  • @JonG I have not seen this extension, sounds perfect. Have you tried to have it in core for newer versions? However, I do think it is a bit too much to install an extension just for this, as I am concerned for the overhead costs of having too many extensions running... – Flying Oct 3 '16 at 18:57
  • @JonG Sorry, had looked at the info.xml file and it said it was compatible with 4.4 – termdark Oct 4 '16 at 23:46
  • @Flying Extensions add relatively little overhead. However, if you'd like to submit this as a patch to core, please do so! – Jon G - Megaphone Tech Oct 6 '16 at 4:10
0

You could schedule a bulk sms mailing (not send immediately), and then go into the database and change two values.

In the table civicrm_mailing, set the value 0 (from 1) on the fields url_tracking and open_tracking

Then you could send (or wait until the scheduled time is met)

0

Disable tracking!

Need to add another 13 chars to sub answer...

  • 1
    But you cannot disable tracking for bulk sms. At least not on 4.4 – Flying Sep 30 '16 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.