5

I'm unable to install CiviCRM extensions from CiviCRM » Administer CiviCRM. On the CiviCRM extensions page I get the following error:

WARNING: The downloader may be unable to download files which require HTTP redirection. This may be a configuration issue with PHP's open_basedir or safe_mode.

When I try to install an extension I get the following errors: CiviCRM error

I've checked and:

The PHP setting open_basedir is not defined. The PHP setting safe_mode is set to off

What's going on?

I've got CiviCRM 4.5.5 installed with Wordpress 4.1.1

  • I have the same issue with one of the hosts that I use, but in my case they do use open_basedir and don't want to stop using it for security reasons. I simply work around it by manually installing the extensions I need either via SFTP or using wget on the command line when logged in via ssh. – Graham Mar 27 '15 at 23:35
4

Try again now. I think Tim has resolved an issue that arose with the need for a new intermediate certificate for the SSL certificate replaced on C.o earlier this week: https://issues.civicrm.org/jira/browse/CRM-16191. Please comment on the issue if your error has been resolved.

  • 1
    This is not fixed for me. I've checked on Chrome and Firefox and get the same error. – frTommy Jun 8 '15 at 18:04
2

I was having the same issue and resolved by bumping my PHP version from 5.3.29 to 5.4.13 -- can you check if this corrects the issue for you?

1

This is not fixed for me trying to add new extension on 4.6.8.

Bug reported: https://issues.civicrm.org/jira/browse/CRM-17263

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.