0

Style tags cannot be saved in message templates and have in fact been stripped from current templates. We use a number of templates based on the Single Column Responsive Sample Template. In the last month, all the templates that used to contain a style tag that made the templates responsive have been stripped from the templates, including the sample template. Any attempts to re-add the style tag (or any style tag at all) seem to save fine, but on viewing do not have the style tag. Other changes are saved properly. I think this is since upgrading to 4.6.22, but am not sure of this.

Style tags can still be saved in CiviMail directly, just not in the templates.

CiviCRM 4.6.22 & Drupal 7.50

3
  • I don't have a good answer, as this seems to be working fine for us in civiCRM 4.6.4 - but it's probably relevant to post which WYSIWYG Editor you're using plus it's version, given the nature of the issue. I did start seeing some certain tags getting stripped and jammed into <style> in unexpected ways when we upgraded to a new version of the full ckEditor. Oct 11 '16 at 21:01
  • We are using CKEditor.
    – Lars SG
    Oct 11 '16 at 21:13
  • This was incorrect, we use CKEditor for CiviMail, but TinyMCE for template editing.
    – Lars SG
    Oct 12 '16 at 4:04
2

Changing from TinyMCE for template editing to CKEditor solved this problem. Verified that switching back to TinyMCE causes style tags to be stripped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.