2

I successfully installed CiviCRM to my wordpress site at josephcommunitycenter.org. When I click on CiviCRM on the left side of the WP Admin panel, it takes a while for the page to load and then I see the following: enter image description here

When I click on Configure Your Dashboard, it goes nowhere. I also don't see the Administer Dashboard for CiviCRM. What is causing this problem? I'm running on php version 5.6 and have the latest version of wordpress and CiviCRM. I can also tell there are some images missing from the CiviCRM Home screen.

Thank you.

  • 1
    I'd guess that you are experiencing a javascript conflict. Some Wordpress themes and plugins don't play nicely with CiviCRM. Some known culprits are mentioned on this page, but it is by no means comprehensive. Try changing your site to use a different theme - opt for one of the basic default ones, and see if the problem persists. If you can see the CiviCRM menu and your dashboard button works, you know where the problem lies. If not the theme, try to disable plugins one by one and see if that changes things. Probably done best on a copy of the site. – Graham Oct 14 '16 at 7:57
  • 1
    I notice in the foot of your screen shot above that 'System Status' is showing 'Error'. Can you click on that and say what it shows? – peterb Oct 14 '16 at 9:10
2

I was able to get it to work by placing this code after the initial

global $civicrm_setting;
$civicrm_setting['Directory Preferences']['customTemplateDir'] = 'public_html/wp-content/plugins/civicrm/civicrm/templates/';
$civicrm_setting['Directory Preferences']['customPHPPathDir'] = 'public_html/wp-content/plugins/civicrm/civicrm/php/';
$civicrm_setting['Directory Preferences']['extensionsDir'] = 'public_html/wp-content/plugins/civicrm/civicrm/extensions/';
$civicrm_setting['URL Preferences']['extensionsURL'] = 'https://www.example.com/wp-content/plugins/civicrm/civicrm/extensions/';
$civicrm_setting['URL Preferences']['imageUploadURL'] = 'https://www.example.com/wp-content/uploads/civicrm/persist/contribute/';
$civicrm_setting['URL Preferences']['userFrameworkResourceURL'] = 'https://www.example.com/wp-content/plugins/civicrm/civicrm/';
0

This is the error message >

System Status: Error Cron Not Running Configure Default Mailbox Complete Setup View details and manage alerts

Also, I already tried changing the theme and deactivating plugins. Nothing worked.

  • That is a standard error message - it will display if cron jobs haven't been set up, if the default configuration hasn't been updated, etc. – Barbara Forbes-Lyons Nov 3 '16 at 19:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.