0

I'm helping a group set up an install (Civi 4.7.12, which has been upgraded from earlier 4.7.x versions a few times) on a dev site and I've added a set of custom fields for a contact sub-type. I added a checkbox field and tested and it worked fine. Now they've added some more custom fields in that set and we are getting some strange errors. I don't see anything which immediately raises a red flag related to the fields they added (more checkbox fields and some text fields).

When editing an existing org and trying to select the sub-type, it throws an error: "Network Error: Unable to reach the server. Please refresh this page in your browser and try again." The custom fields are never shown.

Network error

If I try to create a new contact of this sub-type, the fields show up, but when I try to save the contact, it throws an error. "DB Error: no such field" with further info below:

DB Error: no such field

Fatal error: Uncaught CRM_Core_Exception: [0: Transaction integrity error: Expected to find active frame thrown in /home/public_html/sites/all/modules/civicrm/Civi/Core/Transaction/Manager.php on line 107

Anybody have some pointers for me on where to look? I'm kind of stumped.

  • 1
    That "Network error" message is often misleading. In my experience it typically points to an HTTP error result (error 500 in your case, PHP fatal error), but it can also indicate other HTTP error codes (eg unauthorized, if the request went to a server you're not logged into). (This doesn't answer your underlying issue!) – Chris Burgess Apr 12 '17 at 23:44
  • 1
    Next steps are to inspect your CiviCRM debug log and identify why the DB query failed, then work back from there. – Chris Burgess Apr 12 '17 at 23:45
1

Not a definitive answer yet but it seems to be related to the way they tried to implement comment fields. I disabled all their "Alphanumeric > text" fields and the errors go away. Still having to dig deeper as to what they did (all through the UI) and why it broke things so badly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.