1

I just installed the "Petition Email" extension (2.0) for CiviCRM (4.7.10) under Drupal (7.50). When going to Campaign > New Petition, I get the error

Sorry but we are not able to provide this at the moment. 'civicrm_survey' is not a valid option for field entity_table
1

This is a known issue - see CRM-19286. To fix, upgrade to CiviCRM 4.7.12 or higher.

0

If you can't get it to work as you need you could consider just using webform_civicrm module which gives great functionality for Petitions and much more.

-1

Luckily that's a helpful error message. The code causing the error is on line 182 in petitionemail.php, and the error can be eliminated by commenting out that line.

However, being new to this extension, I don't know if that's affecting functionality. Everything seems to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.