2

After Upgrading from php 5.6 to php 7, when i try to access the sites created using buildkit, I am unable to access it.

After typing

Civibuild show dmaster

I get the following

ERROR: Failed to find required PHP extension "SimpleXML".

TIP: In some systems, the PHP version used in CLI and web are different. >Extensions should be active in both.

the TIP is a bit clear about the change in the PHP version, where do I trick that to work?, and where exactly is that done?

3

It's on your php.ini config file. where it it depends on your OS, in ubuntu/debian it's under /etc/php5 and you have cli and fpm, check that the cli version enables the extension simplexml

FYI, CiviCRM is not yet super tested with php7 (was classified "experimental" two months ago

https://civicrm.org/blog/totten/civicrm-4712-rc-experimental-support-for-php-7-mysql-57

for the details: https://issues.civicrm.org/jira/browse/CRM-17789

X+

  • yes It had to with the php.ini config file. i had to downgrade the php and then it solved the issue – Agbor Nov 2 '16 at 8:38
  • @agbor Please mark this answer solved if it fixed your problem! – Jon G - Megaphone Tech Nov 2 '16 at 11:56
3

It seems to me you need to install the php-xml package.

sudo apt-get install php-xml should get you there on Ubuntu.

  • works fine after installing php7.0-xml – Agbor Nov 16 '16 at 13:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.