4

I've installed the API CSV import GUI extension extension which directs you to "go to the url civicrm/csvimporter/import" to go to the import page, but when I go to Mysite.com/civicrm/csvimporter/import I get an empty page.

I'm having a similar error with Civivisualize which directs you to go to "yoursite.org/civicrm/dataviz". In both cases I'm getting the a blank page. enter image description here

What am I missing here?

=====

I'm on CiviCRM 4.5.5 and Wordpress 4.1.1

8

The URL formula is different for each CMS. The most accurate approach is to open a CiviCRM page and examine its URL. For example, I logged into the public demo sites for v4.5, navigated to "Contributions => Dashboard", and the URL of each page:

All of these are displaying the same logical page, which is canonically identified as "civicrm/contribute". However, each CMS requires a slightly different prefix to it. You can construct URLs for other pages by swapping the "civicrm/contribute" part. So csvimporter's page (if it were installed) would be:

It doesn't seem like a good idea to ask an extension-user to figure out this URL by themselves. Instead, the extension should compute the URL and display it. This can be done with CRM_Utils_System::url() -- e.g. "CRM_Utils_System::url('civicrm/csvimporter/import')".

2

You may need to set up two things for your extensions, and you need to convert the shortform 'URL' provided into a full URL that goes to correct page under your CMS. The image appears to indicate you're running WordPress so I am using URLs for that CMS.

  1. Navigate to Administer > System Settings > Directories (http://yourWordpressSite.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/setting/path&reset=1). Copy the value from CUstom Files field to CiviCRM Extensions Directory field, and change the last level of the directory name from /custom/ to /extensions/ . The value will likely be /wp-content/plugins/files/civicrm/extensions/ . You need to create this directory and ensure it is writeable by the webserver process.
  2. Navigate to Administer > System Settings > Resource URLs (http://yourWordpressSite.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/admin/setting/url&reset=1. In Extension resource URL, enter http://yourWordpressSite.org/wp-content/plugins/files/civicrm/extensions/

Once you are done this, the extensions should be working. Now you just need to navigate to their page. To do this on a WordPress site you need to insert the shortform 'URL' provided in your instructions into a specific part of the full URL for you site. While on a URL for a CiviCRM part of your site, replace everything from &q= to the end with the shortform 'URL', then append &reset=1 . The result should be something like http://yourWordpressSite.org/wp-admin/admin.php?page=CiviCRM&q=civicrm/csvimporter/import&reset=1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.