1

Set up a scheduled task with my web host using the recommended:

/usr/bin/php5 /home/sites/mysite.com/public_html/en/administrator/components/com_civicrm/civicrm/bin/cron.php?name=USER&pass=PASS&key=APIKEY

Keep getting error message: Cron Not Running. No cron runs have been recorded.

Using Joomla 3.6.4

  • Please run the command you've pasted above when shelled into the host, and add the output to your question. Hard to tell you what's going wrong without any information about it :) – Chris Burgess Nov 10 '16 at 4:06
  • Just ran the command from the host as a test and this was the result: Your script returned the following: There was an error testing your cron job. – Tally Nov 10 '16 at 9:34
  • I also tried running a file called test.php which I placed in exactly the same place as the cron.php file. The test.php file contained the following: <?php echo "Success"; ?> When I ran this test when shelled into the host it returned the response: Success so this seems to me to suggest that there is somehow a problem within CiviCRM? – Tally Nov 10 '16 at 9:40
  • In the following string: name=USER&pass=PASS&key=APIKEY – Tally Nov 10 '16 at 9:44
  • I have set the USER as the name of the person in the organisation who is going to be updating CiviCRM. This is her Joomla username. The PASS I've set as her Joomla login password and the APIKEY is the CiviCRM key Is this correct? – Tally Nov 10 '16 at 9:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.