2

When testing the functionality of checksum tokens for a mailing, the link is properly created according to this wiki entry for profile pages (.../?page=CiviCRM&q=civicrm/profile/edit&reset=1&gid=N&{contact.checksum}&id={contact.contact_id}). However, clicking the link leads to an empty page that shows the profile title twice, but no other content.

Interesting: When clicking on Wordpress' customize button, the profile including the respective data is shown above the page – although home page instead of the CiviCRM page.

We're on CiviCRM 4.7.8 for Wordpress (Graphy theme) and are trying to set this up for the first time.

What I tried:

  • Using a different browser (Firefox and Chrome) and different devices (Windows PC and Android Phone) didn't show any differences.
  • I wasn't sure whether a reCAPTCHA would cause problems so I turned it off for this profile, but that didn't help.
  • Clearing cache and resetting paths didn't change anything either.
  • Not sure if this is relevant, but the sidebar is also shown despite having changed the WP template to "no sidebar".

Any other ideas what could cause this?

  • In the URL.../?page=CiviCRM&q=civicrm/profile/edit&reset=1&gid=N&{contact.checksum}&id={contact.contact_id}, did you remember to change the letter N to the exact ID of the Profile you want to send the checksum to? You can find the profile Id at Administer>Customize data...>Profiles – peterb Nov 12 '16 at 16:26
  • Yes, I did. Also, it should the correct id, because the data is shown if I click customize in the black WP bar at the top of the page. This couldn't be permission-related, could it? However, there is no message regarding permission... – Andy Nov 14 '16 at 16:44
  • 1
    Just a few more thoughts: 1. In the civicrm menu administer>Customize data..>Profiles>Profile Title>More>Preview, does the preview show the correct fields? 2. I'm not sure what you mean by the WP bar and customize at the top of the page. Can you show a screenshot? 3. Have you tried doing all this with another theme in case the problem is theme related? – peterb Nov 15 '16 at 12:09
  • After some tinkering, I found the problem. I sincerely apologise for my stupidity. The link was incorrect. Instead of .../civicrm/?page=CiviCRM&q=civicrm/profile/edit&gid=16&reset=1&gid=16&{contact.checksum}&id={contact.contact_id} I used .../?page=CiviCRM&q=civicrm/profile/edit&reset=1&gid=16&{contact.checksum}&id={contact.contact_id} Problem is now solved... – Andy Nov 29 '16 at 16:10
  • Nice to know you solved it. Perhaps you could now file your comment as "Your Answer" below so that others will see it. – peterb Nov 29 '16 at 18:20
1

It seems only the link was incorrect and lead to the explained behaviour. The wiki entry over at civicrm.org is inaccurate (for Wordpress installations at least). The suggested link is

.../?page=CiviCRM&q=civicrm/profile/edit&reset=1&gid=N&{con‌​tact.checksum}&id={c‌​ontact.contact_id}

while in my case the correct link is

.../civicrm/?page=CiviCRM&q=civicrm/profile/edit&gid=N&rese‌​t=1&gid=16&{contact.‌​checksum}&id={contac‌​t.contact_id}

I realised the link was missing the "civicrm" part, when I tested the profile in "create mode", which gave me the correct (second) link. Hopefully, someone else may find this useful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.