1

I have installed civicrm 4.7 on drupal 7. Installing of extension failed with error:

DROP FUNCTION IF EXISTS civicrm_strip_non_numeric [nativecode=1370 ** alter routine command denied to user 'civicrm'@'localhost' for routine 'civicrm.civicrm_strip_non_numeric']

I have grant all to the database, named civicrm.

  • Which extension are you installing, and how did you try to install it -- from the Manage Extensions screen or manually by putting the files in your extension directory? – Allen Hutchison Nov 15 '16 at 17:32
  • Thanks for the answers. I have already tried the "GRANT ALL" command before. It did not fix the error. Also, i have tried the civicrm_dbtools, but it isn't support the version ("FATAL: Don't recognize version 4.7.12"). – Thomas Nov 16 '16 at 8:14
  • Okay, I gave the persmissions with "GRANT ALL" again and it works. Thank you very much :-) – Thomas Nov 16 '16 at 8:35
  • I installed CiviSepa, which is not from the public extension directory and put it to the extension directory – Thomas Nov 16 '16 at 15:38
2

Some permissions won't be granted when you use 'GRANT ALL' before the database has been created. Rerunning your GRANT ALL should fix the problem.

3

The user does not have the permissions to alter and create routines (functions). This should fix it:

GRANT CREATE ROUTINE, ALTER ROUTINE ON civicrm.* TO civicrm;
  • This is probably correct, but you should address the question's claim to have already granted all. – Alan Dixon Nov 15 '16 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.