2

On a PC, I've downloaded a list into excel and saved it as a MS-DOS CSV file. When I go to Civi to import it, Civi says it's not saved as a CSV file.

I've followed the same steps I have for a dozen other contact lists.

What am I missing?

  • 1
    William's answer is a good one - but more broadly, this sounds like a "character encoding" issue. – Jon G - Megaphone Tech Nov 16 '16 at 19:46
1

I would suggest that you take a look at the documentation: Importing Data into CiviCRM

Read through this and follow the steps carefully. Try to export a small number of contacts - i.e. the first ten or so. If you are able to import these then the problem may be with some of the data in the later records.

You may need to change the export settings so that fields are separated by a semicolon (;) rather than a comma (,).

You may find the answers to this related post helpful: CSV file import problem with file from Mac MS Office

If you are still having trouble it would be helpful if you could paste an example of the CSV file to your post with dummy data replacing any real data. Again, just the first few lines would be sufficient.

1

In some cases I have found that saving a csv that has been edited and resaved results in this type of behaviour. Solution in those cases was just

  • open the csv
  • copy all content
  • paste in new csv, save, close, do not reopen or edit etc

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.