2

We have an html email message that won't save and it seems related to size. if we remove a table or a few characters, we can save. But once we hit this unknown limit, we can't save a blank space. We can't make any more changes.

Anyone else run into this and know where the settings are to change this?

  • When you insert your code are you including the <html> & <body> tags? I have had similar issue intermittently. I have found if I only include only the HTML for layout it works. – KilakwaBT Nov 16 '16 at 21:24
  • Yes we have those tags. – Nina Gonzalez Nov 23 '16 at 18:32
2

body_text and body_html are the fields in the database that store these values, and the are of type 'longtext', which are of size 4Gb. So you're probably not hitting this limitation.

More likely, it's your php.ini configuration that is limiting the size of your "posting" (i.e. post_max_size), or a mysql limitation (e.g. max_allowed_packet).

It's also easy to put way too much bad html into these fields, particularly if you're copy/pasting from say, Word. If you take a look at your source, you might find a bunch of html you can and should remove.

  • Yes you are correct. This problem seems to be related to bad code. Although our code past a W3 test and mailchimp and various email client tests, it had nested tables and unnecessary code. We create a new template with clean code and it works fine. CiviMail is obviously much more sensitive than most email programs. – Nina Gonzalez Nov 23 '16 at 18:33
  • Actually, your comment suggests that the technical aspect of the problem is your php or mysql settings, it's not a CiviCRM limitation you're running into. CiviCRM doesn't care about the quality or quantity of your html. But since it helped you remove some unnecessary code, I guess that's a good thing. – Alan Dixon Nov 23 '16 at 19:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.