2

I upgraded from 4.5.4 to 4.7.13 (on Drupal); I didn't receive any errors during the upgrade process, but now when I try to create or edit a contact, I get an unsupported html-element, similar to what was reported at After upgrade to 4.7 on Drupal 7, Can't edit a contact.

The backtrace looks like this:

#0 /var/www/drupal/sites/all/modules/civicrm/CRM/Contact/Form/Edit/Individual.php(77): CRM_Core_Form->addField("prefix_id", (Array:3))
#1 /var/www/drupal/sites/all/modules/civicrm/CRM/Contact/Form/Contact.php(755): CRM_Contact_Form_Edit_Individual::buildQuickForm(Object(CRM_Contact_Form_Contact))
#2 /var/www/drupal/sites/all/modules/civicrm/CRM/Core/Form.php(548): CRM_Contact_Form_Contact->buildQuickForm()
#3 /var/www/drupal/sites/all/modules/civicrm/CRM/Core/QuickForm/Action/Display.php(92): CRM_Core_Form->buildForm()
#4 /var/www/drupal/sites/all/modules/civicrm/packages/HTML/QuickForm/Controller.php(203): CRM_Core_QuickForm_Action_Display->perform(Object(CRM_Contact_Form_Contact), "display")
#5 /var/www/drupal/sites/all/modules/civicrm/packages/HTML/QuickForm/Page.php(103): HTML_QuickForm_Controller->handle(Object(CRM_Contact_Form_Contact), "display")
#6 /var/www/drupal/sites/all/modules/civicrm/CRM/Core/Controller.php(351): HTML_QuickForm_Page->handle("display")
#7 /var/www/drupal/sites/all/modules/civicrm/CRM/Utils/Wrapper.php(113): CRM_Core_Controller->run()
#8 /var/www/drupal/sites/all/modules/civicrm/CRM/Core/Invoke.php(286): CRM_Utils_Wrapper->run("CRM_Contact_Form_Contact", "New Contact", (Array:1))
#9 /var/www/drupal/sites/all/modules/civicrm/CRM/Core/Invoke.php(86): CRM_Core_Invoke::runItem((Array:13))
#10 /var/www/drupal/sites/all/modules/civicrm/CRM/Core/Invoke.php(54): CRM_Core_Invoke::_invoke((Array:3))
#11 /var/www/drupal/sites/all/modules/civicrm/drupal/civicrm.module(448): CRM_Core_Invoke::invoke((Array:3))
#12 [internal function](): civicrm_invoke("contact", "add")
#13 /var/www/drupal/includes/menu.inc(527): call_user_func_array("civicrm_invoke", (Array:2))
#14 /var/www/drupal/index.php(21): menu_execute_active_handler()
#15 {main}

Additionally, when I disable displaying the prefix (in Administration -> Option Groups -> Contact Edit Options) the top error line becomes:

#0 /var/www/drupal/sites/all/modules/civicrm/CRM/Contact/Form/Edit/Individual.php(77): CRM_Core_Form->addField("first_name", (Array:0))

Obviously, I don't want to disable the first name as well.

1

This is a known issue and applying following patch should fix this issue. https://github.com/civicrm/civicrm-core/pull/7770/files

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy