2

As of title, I'm looking for a CiviCRM version that does not require trigger privileges, since the hosting service that I'm using does not support it, currently I'm on version CiviCRM 4.7.13 and getting this error when I try to create a new contact:

"Sorry but we are not able to provide this at the moment. DB Error: insufficient permissions"

these are the privileges on my user from MySQL:
GRANT SELECT, INSERT, UPDATE, DELETE, CREATE, DROP, INDEX, ALTER, LOCK TABLES ON db1234.* TO 'usr1234'

5

I'd recommend approaching the problem the other way round: find a hoster that works with the latest versions of Civi rather than find a version of Civi that works with your current hoster. You will be missing out on many new features and security fixes if you choose to run an old version. It will only bite you later.

Is there any reason not to move hoster? As ErikH points out, there are several specialist CiviCRM hosting services - but not all are equal. See eg How to evaluate hosted CiviCrm enviroments

4

I think earlier than CiviCRM 4.3 does not require trigger priviliges but I do expect you to run into other issues with your hosting service. I recommend you go to a experienced CiviCRM hosting service like CiviHosting?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.