After clicking "disable" on the Stripe extension, visiting civi gave me an error 500 and does not make an entry in the error log. But going to Drupal home kicks out the following error message:

Warning: require_once(CRM/Core/Payment/Stripe.php): failed to open stream: No such file or directory in Civi\Payment\System::getByProcessor() (line 59 of /home/ourbase/public_html/prbrc/sites/all/modules/civicrm/Civi/Payment/System.php).

The file it's looking for does exist, BTW.

I've fixed this before (see answer), but I just want to uninstall the extension -- it never for us worked anyway.


1 Answer 1


Getting your site back online, in phpmyadmin:

  1. In table civicrm_extension, enable stripe (change 0 to 1)
  2. In table payment_processor, disable any using stripe (change 1 to 0)

This should allow your site to load.

Deleting stripe (warning: stripe may be related to some transactions, check before doing this):

  • Make sure none of your donation pages are using stripe
  • Delete any payment methods using stripe
  • Delete the payment processor "stripe"
  • Disable extension "stripe"
  • Uninstall extension "stripe"

You'll still see it on the list of extensions with an install link. To get rid of it, you'll have to remove the com.drastikbydesign.stripe folder in /sites/default/files/civicrm/extension (or whatever your extensions directory is).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.