1

I did a first mailing and then got the bounce processing job working. It just moved all the bounce responses (about 100) to the ignore mailbox and did not mark any of my contacts. How do I tell what went wrong? There is no info in the log other than saying that it rand the job successfully.

Also I got emails of the form: To: u.68.3087.7ed8aa555f763f19@californiacalvary.org iOS Mail sent this email to unsubscribe from the message “One Week To Go!”.

Should these get processed?

  • The spelling in californiacalvary.org catches my eye (sorry, I'm like that). I wonder if your CiviCRM is ignoring the bounce emails because it's configured to expect bounces to californiacavalry.org? Looks like you have both domains registered - ✝ vs 🏇 ? – Chris Burgess Dec 5 '16 at 22:47
  • Interesting point. The person who came up with the name misspelled it and being a lousy speller I just trusted. We have both domains with the calvary one parked on the correct spelling of cavalry. It does seem that the bounced emails are to the wrong spelling. I must have something still configured the other way. – Mike Ubell Dec 6 '16 at 1:11
  • Worth eliminating. If you enable debugging on your site, debug log will show when CiviCRM ignores some emails. See relevant code here, look for markIgnored(). – Chris Burgess Dec 6 '16 at 1:49
  • Suggests either CiviCRM failed to parse the email, or didn't match recipient (possibly b/c wrong domain?). – Chris Burgess Dec 6 '16 at 1:50
  • Being a newbie, I am not sure how to turn on debugging. I tried Administrator->Debugging and Error Handling and turned on debugging. There is no additional output in the Bounce job log. – Mike Ubell Dec 6 '16 at 3:59
1

It looks like CiviCRM uses the domain specified in the bounce mailbox settings to generate a regex to match incoming bounce messages.

From the info in your question, I suspect CiviCRM is directing bounces to a (subtly) different domain name. As a result, it doesn't think the bounces are intended for CiviCRM to process, and moves them to the ignored folder (as CiviCRM would with other "not for me" email).

See your mail account settings (Admin > CiviMail > Mail Accounts).

Try ensuring both the return address and site domain match, and see if the problem persists.

Once correctly configured (or, temporarily misconfigured to match the misspelled inbound address!), you can move those messages back from the CiviCRM.ignored mailbox to the INBOX, and re-process them.

  • Apparently the misspelling persisted after a domain change, possibly cached. It is now gone. I would hate to have that domain reinstalled. I am planning on downloading and editing the emails to put the correct domain in them and then sending them back. Do you happen to know if the bounce processor will handle multiple bounce info in one email or do they have to be separate emails? – Mike Ubell Dec 6 '16 at 23:44
  • You should mark your question here as answered :) ... I feel like it should be possible for you to reconfigure CiviCRM temporarily to accept the "wrong" domain for those bounces, move them from CiviCRM.ignored to INBOX, run the bounce processor, then configure CiviCRM back to use the "proper" domain. Downloading and uploading the previous set of bounces might not go as smoothly as you expect. (I don't know, haven't tried.) – Chris Burgess Dec 7 '16 at 4:40
  • I am not clear where to change the domain. It is not clear what it uses to generate the X-CiviMail-Bounce domain. Is it the bounce email address or the domain of the site? When I switched my site from my hosting domain to my real one it was down till someone went in and edited the database, so I will not casually change it again. If there are specific instructions on exactly what I should change I will do that. – Mike Ubell Dec 7 '16 at 17:41
  • Ok. It seems that sending the mail to the b. generated address does the trick. Glancing through the code it looked like just having the X-CiviMail-Bounce record should be sufficient, but I guess not. – Mike Ubell Dec 8 '16 at 20:43
  • Yay! Good work for persisting :D – Chris Burgess Dec 9 '16 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.