2

In WordPress and Civi 4.7.13, CKEditor replaces & with

&

This inherently breaks using smarty in mail/PDF templates. How are other people getting around this one?

I've tried setting forceSimpleAmpersand in files/civicrm/persist/crm-ckeditor-config.js as per the CKEditor docs, but I can't get it to have any effect. Other settings in the same config file do work, so I know that file is ok.

This setting did work in the older version of CKEditor in 4.6.x, annoyingly.

  • We've verified that forceSimpleAmpersand is a bug, and filed an issue with CKEditor. Hopefully they'll fix soon. I don't have a good workaround for dealing with the issues this causes with smarty in mailing/PDF templates, though. – Andrew West Dec 16 '16 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.