1

So I'm trying to set up CiviCRM on my wordpress site hosted by GoDaddy. I called them to help get the plugin installed, which was fine. Once I go to our WP dashboard and begin the setup process for CiviCRM, at the top it shows the error message:

Warning: mysqli_real_escape_string() expects parameter 1 to be mysqli, boolean given in /home/content/p3pnexwpnas12_data02/23/3646623/html/wp-content/plugins/civicrm/civicrm/install/index.php on line 1256

Ignoring that, I went ahead to set everything else up. It should be connecting to the existing WP database, however, it doesn't. I get the following still:

Your database settings don't appear to be correct. Please check the Database Details below for specific errors. 

I called GoDaddy to verify and they said the settings were correct.

Any suggestions?

1

I had a GoDaddy Managed WordPress account and the same is happening to me. I've checked all information (db server, username, password, database) and all seem correct. But still the got message "Your database settings don't appear to be correct. Please check the Database Details below for specific errors."

After many calls to GoDaddy support, I gave up and changed to a regular shared hosting account with cPanel. This time the CiviCRM setup worked as expected and everything is working perfectly.

GoDaddy didn't provide a good answer, so my guess is that Managed WordPress hosting doesn't provide the access required by CiviCRM.

Hope this helps in any way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.