I'm getting this System Status notice:

The Following Option Values contain value fields that do not match the Data Type of the Option Group

It references an option group with 0 as one of the values. The group is used for a custom field of type Number. I went into the mysql database and saw that the option group had type String, so I changed that to Integer, also tried Float - nothing got rid of the error.

Is it a spurious error due to a bug or am I not understanding something about how option groups and values work?

  • I've seen the same thing, plus now I have a complaint about a custom radio button field. It's ironic/amusing/or a bug that Civi is complaining about something that it was quite happy for me to do through the UI.
    – Andy Clark
    Commented Dec 8, 2016 at 22:29

1 Answer 1


We finally poked around and noticed standard option groups with integer values did not use zero. We had used value zero to represent "No". We changed "No" to value 3 and updated the existing records. Once all zeroes were gone, the warning disappeared. Later, we noticed that other radio button option groups use Alphanumeric data type even if the values are integers. Ours had been configured as an Integer (INT11 in the database). I can't say whether either of these conditions are the root of the warning, but avoiding zero appears to have worked. See also:

Option Values with problematic Values

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.