Civi version: civicrm-4.7.14-wordpress | Wordpress version: 4.7


I have run into a problem with a Civi/WordPress install. The content of the dashboard is not loading and the Civi menu not showing. The site is installed in a directory and the urls for 34 Civi include files have that directory duplicated. This is a new install. The only concern during the install was that the server is running PHP 5.4, otherwise it went fine.

Example URL: domainName/dir/dir/wp-content/plugins/civicrm/civicrm/css/crm-i.css?r=YR5cm

I am still relatively new to Civi and I am having trouble sorting out where to correct the duplication. Any recommendations would be very appreciated.


ADD. 1: If it's of any help, I've confirmed there are no Javascript errors (probably because none of the Civi includes are loading), Wordpress itself is running fine, there are no other plugins installed, and the theme is Twenty Seventeen.

ADD. 2: I confirmed with the host that everything is okay on their end.

I removed the directory from civicrm.settings.php, line 211

define( 'CIVICRM_UF_BASEURL' , 'domainURL/dummy');

Now the dashboard at least tries to load, but generates the error "Network Error, Unable to reach the server". The 404 errors are gone now. There is still no Civi Admin menu but I am at least able to access the Administer CiviCRM page and its links now. Unfortunately, it also means I have to manually add the directory back into URLs that didn't have the duplication to start with, like the "System Status" link at the bottom of the dashboard.

ADD. 3: I tried installing CiviCRM Utilities plugin as suggested on "Word Press Install Missing civicrm.settings.php; dashboard unavailable; no menus" (I don't have enough points to post more than one link)

It didn't resolve the problem but I now have the following appearing on Civi dashboard. That's progress of a sort... I guess.

enter image description here

Now I'm looking at resolving these issues. Sigh.
I'm willing to entertain even the smallest shot in the dark for the original problem at this point.


1 Answer 1


The problem I am experiencing is related to this issue Word Press Install Missing civicrm.settings.php; dashboard unavailable; no menus

The override provided has the site up and running. Yay!

(If someone can relay my thanks to Kevin Cristiano I'd really appreciate it!)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.