1

"unknown path" error when trying to access Mailings/New Mailing. This only seems to occur with Safari on a mac (and on an iPhone)and is the result of the correct url being truncated (see below).

This subject came up a year ago and I posted this under that thread but have been encouraged to post it as a new question.

Our site is at Drupal 7.52/Civi 4.7.13 and another site with same issue is at Drupal 7.50 and I'm not positive which civi version.

Further clues: The url box at the top of the browser very quickly cycles through the following three urls when I choose "New Mailing"

1) my_domain.com/civicrm/mailing/send?reset=1
2) my_domain.com/civicrm/a/#/mailing/new
3) my_domain.com/civicrm/a

On other browsers (Chrome on same Mac) the third url is correct..
1) my_domain.com/civicrm/mailing/send?reset=1
2) my_domain.com/civicrm/a/#/mailing/new
3) my_domain.com/civicrm/a/#/mailing/462

As you can see, the url is being stripped beginning with /# This is happening on at least a couple of sites as I note above, and they are on different, but all recent, versions of Drupal and Civi. It feels like some url rewrite or redirect process is stumbling, and it is browser specific...

Perhaps there has been an update to Safari that's reawakening an error from a year ago? I'm on Safari Version 10.0.1 (11602.2.14.0.7). I'm not sure how to tell when it was updated on my computer, but others are having this problem when accessing both these sites with Macs.

The previous thread

'Unknown path' error when trying to access New Mailing with version 4.6.2

explored Global Redirect Module being the culprit, or perhaps errors in the Send.php file - we don't have that redirect module (but do have 301 Redirect module) but disabling it and making the changes to the Send.php file don't change the problem

Per above, I tried changing 'civicrm/a/' to 'civicrm/a' in lines 53,59,62,68 of my ...sites/all/modules/civicrm/CRM/Mailing/Controller/Send.php file and it didn't change the behavior.

  • Is your site a Drupal multisite? If so then CRM-19303: CKEditor configuration can't be edited on a Drupal multisite installation might be of interest. – Chris Burgess Dec 11 '16 at 22:53
  • Thanks for the idea, but no, neither of these sites is Drupal Multisite. – Rick Cunningham Dec 12 '16 at 2:21
  • Sorry for a newbie question, but is there an easy way to single step my browser through the url chain that's happening here? Since this doesn't occur with Chrome on PC or Mac, I'm hypothesizing that something in the Safari engine winds up corrupting the url - the url rewrites that the send.php file generates look OK through 2 of the three steps, then get truncated in the third. – Rick Cunningham Dec 13 '16 at 11:11
  • I was unable to reproduce this on the matching CiviCRM demo site using matching Safari version v10.0.1 (11602.2.14.0.7). This seems like it might be a server config or external module issue, but I believe you'll need to debug the site in question to resolve this. Note that the second URL change is not an HTTP redirect, but an update to Angular's $location state (uncertain of exact terminology). Here's a question on how to debug changes in Angular's URL hash. – Chris Burgess Dec 13 '16 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.